Bug 1258930 - AttributeError: 'module' object has no attribute 'GROUP_DEFAULT'
AttributeError: 'module' object has no attribute 'GROUP_DEFAULT'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jan Blazek
Release Test Team
: Reopened
: 1308513 (view as bug list)
Depends On:
Blocks: 1172230 1303741
  Show dependency treegraph
 
Reported: 2015-09-01 10:28 EDT by Joey Boggs
Modified: 2017-09-06 04:42 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 08:12:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Chris Lumens 2015-09-01 10:36:33 EDT
I don't know what package includes livecd-creator in RHEL7, but it'll need to be updated for the pykickstart rebase.  GROUP_DEFAULT has always been in pykickstart.constants, but sloppy importing allowed people to do things like use pykickstart.parser.GROUP_DEFAULT.  In particular, I got rid of wildcard imports and started using __all__ in various places.  The much more recent version of pykickstart in RHEL7 now is stricter about its imports, so you'll need to grab that constant from its real location.
Comment 10 David Cantrell 2016-01-25 11:48:14 EST
Per comments #5 and #9, I am closing this bug.  It's not a bug in pykickstart.  There are changes (see #5) that need to go in to livecd-tools.  I would reassign the bug to livecd-tools, but that component does not exist for RHEL-7 in Bugzilla.
Comment 11 Fabian Deutsch 2016-02-02 03:43:51 EST
This bug popped up in bug 1303741 again - Can someone rebuild livecd-tools with the correct patches?
Comment 14 Tomas Mlcoch 2016-02-15 07:47:28 EST
*** Bug 1308513 has been marked as a duplicate of this bug. ***
Comment 16 Tomas Mlcoch 2016-02-16 05:50:12 EST
livecd-tools-20.4-1.6.el7 which resolves this issue is available and tagged into rhel-7.3-build

https://brewweb.devel.redhat.com/buildinfo?buildID=480542
Comment 17 Fabian Deutsch 2016-02-16 07:18:48 EST
Tomas, can you also do a RHEL 7.2 build?
Comment 19 Tomas Mlcoch 2016-02-16 10:27:13 EST
Fabian, I'm not RHEL-7 releng so I wanted to avoid do any retrospective changes in RHEL-7.2.
What exactly do you need? Do you want the package in rhel-7.2-build or in rhel-7.2-z-build or in both and why do you need it?
Comment 20 Marina 2016-02-16 15:56:09 EST
Probably the z-build. 
But maybe Joey can help?
Comment 22 Lubos Kocman 2017-09-06 04:42:43 EDT
Just to note thatwe'll ship this as part of buildroot-only in https://errata.devel.redhat.com/advisory/30070

This is blocking virt-p2v and we'll no longer have to set overrides

Lubos

Note You need to log in before you can comment on or make changes to this bug.