Bug 125896 - Segfault on loading gtk-ok.png
Segfault on loading gtk-ok.png
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-13 10:45 EDT by Michael Soulier
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 14:08:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Soulier 2004-06-13 10:45:22 EDT
Hello,

I am using wxPython wxPythonGTK2-py2.2-2.5.1.5-1, which uses GTK2, and
I'm having a problem with it. 

When I try to pop up a dialog box using the stock ok icon, I get this:

free(): invalid pointer 0x9f5ab60!

(wxctw:1155): Gtk-WARNING **: Error loading icon: Failed to load image
'/usr/share/icons/Bluecurve/20x20/stock/gtk-ok.png': Fatal error in
PNG image file: invalid stored block lengths
Segmentation fault

I can load that image just fine in the gimp, so I'm not sure what the
issue is, but it's coming from the GTK2 layer apparently.

I'm using gtk2-2.2.4-5.1
Comment 1 Matthias Clasen 2004-06-25 23:56:53 EDT
Does this still occur with gtk2 2.4.x ?
What version of libpng ?
Do you have a stacktrace ?
Comment 2 Michael Soulier 2004-06-27 21:25:43 EDT
> Does this still occur with gtk2 2.4.x ?

I haven't tried it. I'm using FC 1. 

> What version of libpng ?

libpng-1.2.2-20

> Do you have a stacktrace ?

No. I'd have to reinstall the broken wxPython to get one. It should be
fully
reproduceable on FC 1. 
Comment 3 Matthias Clasen 2004-07-14 14:08:58 EDT
Works for me in rawhide, so I assume it was fixed by the libpng fixes
which happened since fc1. 

Note You need to log in before you can comment on or make changes to this bug.