Bug 1258975 - packaging: gluster-server install failure due to %ghost of hooks/.../delete
packaging: gluster-server install failure due to %ghost of hooks/.../delete
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: packaging (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Reopened, Triaged
Depends On:
Blocks: 1258976
  Show dependency treegraph
 
Reported: 2015-09-01 12:00 EDT by Kaleb KEITHLEY
Modified: 2016-06-16 09:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1258976 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:34:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-09-01 12:00:27 EDT
Description of problem:

incorrect ghost:

  %ghost %dir %attr(0755,-,-) %{_sharedstatedir}/glusterd/hooks/1/delete

causes install to fail with a cpio mkdir error.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2015-09-01 12:17:36 EDT
REVIEW: http://review.gluster.org/12080 (packaging: incorrect %ghost of .../hooks/1/delete causes install failure) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Niels de Vos 2016-06-16 09:34:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.