Bug 1258986 - Update livemedia-creator example kickstarts to remove random-seed
Update livemedia-creator example kickstarts to remove random-seed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lorax (Show other bugs)
7.2
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 12:35 EDT by Brian Lane
Modified: 2015-11-19 04:41 EST (History)
3 users (show)

See Also:
Fixed In Version: lorax-19.6.66-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 04:41:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2289 normal SHIPPED_LIVE lorax bug fix and enhancement update 2015-11-19 04:44:13 EST

  None (edit)
Description Brian Lane 2015-09-01 12:35:49 EDT
Description of problem:
Installation to a disk image creates /var/lib/systemd/random-seed which is used to add entropy to /dev/urandom at boot time. Live isos and disk images used for multiple systems should not seed /dev/urandom

Version-Release number of selected component (if applicable):
lorax-19.6.64-1

How reproducible:
Always

Steps to Reproduce:
Create a disk image or live iso with livemedia-creator.

Actual results:
/var/lib/systemd/random-seed exists on the disk image.

Expected results:
No random-seed file

Additional info:
The fix is simple, add this to the  %post of the example kickstarts:

rm /var/lib/systemd/random-seed
Comment 1 Brian Lane 2015-09-01 12:47:04 EDT
Proposed patch: https://github.com/rhinstaller/lorax/pull/48
Comment 3 Jan Stodola 2015-09-04 10:53:28 EDT
Brian, there is one kickstart: /usr/share/doc/lorax-19.6.66/rhel-atomic-pxe-live.ks that doesn't remove /var/lib/systemd/random-seed in %post. Is it expected?
Comment 4 Brian Lane 2015-09-09 20:09:27 EDT
(In reply to Jan Stodola from comment #3)
> Brian, there is one kickstart:
> /usr/share/doc/lorax-19.6.66/rhel-atomic-pxe-live.ks that doesn't remove
> /var/lib/systemd/random-seed in %post. Is it expected?

No, atomic doesn't have random-seed in it.
Comment 5 Jan Stodola 2015-09-10 12:20:58 EDT
OK, thanks.

This is fixed in lorax-19.6.66-1.el7, moving to VERIFIED.

# grep -C1 "rm /var/lib/systemd/random-seed" *.ks
fedora-minimized.ks-# Remove random-seed
fedora-minimized.ks:rm /var/lib/systemd/random-seed
fedora-minimized.ks-%end
--
rhel7-livemedia.ks-# Remove random-seed
rhel7-livemedia.ks:rm /var/lib/systemd/random-seed
rhel7-livemedia.ks-%end
--
rhel7-minimal.ks-# Remove random-seed
rhel7-minimal.ks:rm /var/lib/systemd/random-seed
rhel7-minimal.ks-%end
#
Comment 7 errata-xmlrpc 2015-11-19 04:41:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2289.html

Note You need to log in before you can comment on or make changes to this bug.