Bug 1258992 - [abrt] initial-setup: __init__.py:135:prompt:TypeError: 'dict_values' object does not support indexing
[abrt] initial-setup: __init__.py:135:prompt:TypeError: 'dict_values' object ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Kolman
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:d2202fe990553d634906e69f34f...
:
Depends On:
Blocks: F23BetaBlocker
  Show dependency treegraph
 
Reported: 2015-09-01 13:05 EDT by Giulio 'juliuxpigface'
Modified: 2015-09-10 17:37 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-23.19.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-10 17:37:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (678 bytes, text/plain)
2015-09-01 13:05 EDT, Giulio 'juliuxpigface'
no flags Details
File: environ (116 bytes, text/plain)
2015-09-01 13:05 EDT, Giulio 'juliuxpigface'
no flags Details

  None (edit)
Description Giulio 'juliuxpigface' 2015-09-01 13:05:16 EDT
Description of problem:
Steps to reproduce:
1. Install Fedora 23 Alpha TC1 on a qemu-kvm guest (I chose to install from the live of KDE x86_64).
2. Do not create an user with Anaconda.
3. Boot the installed system.
4. Observe that initial-setup keep failing (with a looping exception).
5. The system must be shut down improperly (I used CTRL+ALT+BACKSPACE in order to reboot mine).

Workaround:
1. But the system in single mode.
2. Log in as root.
3. systemctl disable initial-setup-text.service.
4. Reboot and observe that initial-setup-graphical works as expected.

Version-Release number of selected component:
initial-setup-0.3.35-1.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        python3 -m initial_setup
executable:     /usr/lib/python3.4/site-packages/initial_setup/__main__.py
kernel:         4.2.0-0.rc6.git0.2.fc23.x86_64
runlevel:       unknown
type:           Python3
uid:            0

Truncated backtrace:
__init__.py:135:prompt:TypeError: 'dict_values' object does not support indexing

Traceback (most recent call last):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 346, in _mainloop
    prompt = last_screen.prompt(self._screens[-1][1])
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/hubs/__init__.py", line 135, in prompt
    'spoke_title': self._spokes.values()[0].title,
TypeError: 'dict_values' object does not support indexing

Local variables in innermost frame:
args: None
__class__: <class 'pyanaconda.ui.tui.hubs.TUIHub'>
self: <initial_setup.tui.hubs.initial_setup_hub.InitialSetupMainHub object at 0x7fd6d9927d68>
Comment 1 Giulio 'juliuxpigface' 2015-09-01 13:05:19 EDT
Created attachment 1069086 [details]
File: backtrace
Comment 2 Giulio 'juliuxpigface' 2015-09-01 13:05:20 EDT
Created attachment 1069087 [details]
File: environ
Comment 3 Fedora Blocker Bugs Application 2015-09-01 13:16:30 EDT
Proposed as a Blocker for 23-beta by Fedora user juliuxpigface using the blocker tracking app because:

 This bug seems to violate the  Alpha criteria "2.4.1 Expected installed system boot behavior" (https://fedoraproject.org/wiki/Fedora_23_Alpha_Release_Criteria#Expected_installed_system_boot_behavior).

"A system installed without a graphical package set must boot to a state where it is possible to log in through at least one of the default virtual consoles."

As it appears to me, initial-setup-text's mainloop crashes and loops until the system's shutdown.
Comment 4 Adam Williamson 2015-09-08 16:15:59 EDT
initial-setup-text does seem to work in Beta TC4. I tested with the Cinnamon live since KDE live compose failed. On my first boot try, it seems like initial-setup-graphical ran but was not visible (I saw the cinnamon login screen). I booted to rescue mode and forcibly disabled initial-setup-graphical, which forced initial-setup-text to run, and it ran OK.
Comment 5 Adam Williamson 2015-09-10 15:04:40 EDT
Discussed at 2015-09-10 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-10/f23-blocker-review.2015-09-10-16.00.log.txt . Accepted as a blocker per criterion cited in #c3 - this would be violated for the ARM minimal disk image, which relies on initial-setup-text for user creation.
Comment 6 Adam Williamson 2015-09-10 17:37:16 EDT
23.19.2-1 went stable, so closing. Note, we should check if the ARM KDE and minimal images actually work in TC5, make sure no other issues are lurking.

Note You need to log in before you can comment on or make changes to this bug.