Bug 1258993 - connections to qpidd fail if SASL is used
connections to qpidd fail if SASL is used
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: 3.2
: ---
Assigned To: Ken Giusti
Messaging QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 13:09 EDT by Ken Giusti
Modified: 2015-10-08 09:11 EDT (History)
5 users (show)

See Also:
Fixed In Version: qpid-cpp-0.34-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 09:11:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-6639 None None None Never

  None (edit)
Description Ken Giusti 2015-09-01 13:09:54 EDT
Description of problem:

A race condition exists in qpid-cpp-server-0.34-2 that causes the client to fail to connect.  The broker logs a connection time out error.


Version-Release number of selected component (if applicable):

qpid-cpp-server-0.34-2

How reproducible:

100% against qpid-dispatch 

Steps to Reproduce:

See JIRA info

Actual results:

Connection attempt fails (times out at broker)

Expected results:

Connection attempt succeeds 

Additional info:
Comment 3 Irina Boverman 2015-09-09 14:21:13 EDT
This patch was already on 0.34-mrg branch.
Comment 7 errata-xmlrpc 2015-10-08 09:11:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1879.html

Note You need to log in before you can comment on or make changes to this bug.