Bug 1259003 - RFE: Provide mechanism to set domain name for overcloud
RFE: Provide mechanism to set domain name for overcloud
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Marios Andreou
yeylon@redhat.com
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 13:28 EDT by Jon Thomas
Modified: 2016-04-18 02:57 EDT (History)
14 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.7-1.el7ost
Doc Type: Enhancement
Doc Text:
The domain name for overcloud nodes defaulted to 'localdomain'. For example: 'overcloud-compute-0.localdomain'. This enhancement provides a parameter (CloudDomain) to customize the domain name. Create an environment file with the CloudDomain parameter included in the 'parameter_defaults" section. If no domain name is defined, the Heat templates default to 'localdomain'.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:39:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1598143 None None None Never
OpenStack gerrit 261018 None None None 2016-01-25 07:14 EST

  None (edit)
Description Jon Thomas 2015-09-01 13:28:15 EDT
Need to set domain name to something other than localhost in overcloud.

This may not be in the correct component or it may be multi-component. 

However, in the templates localdomain is hardcoded. For example,


puppet/controller-puppet.yaml
...
hosts_entry:
    description: >
      Server's IP address and hostname in the /etc/hosts format
    value:
      str_replace:
        template: IP HOST.localdomain HOST CLOUDNAME
...


It would be ideal to have domain configurable at a high level.

thx
Comment 12 Marios Andreou 2016-03-18 06:56:37 EDT
Afaics this bug is fixed by the commit at https://review.openstack.org/#/q/Ie012f9f2a402b0333bebecb5b59565c26a654297,n,z 

That introduces the CloudDomain parameter (defaulting to localdomain) which can be set to some other value as required by the deployer. Moving to POST
Comment 13 Mike McCune 2016-03-28 19:00:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 14 Dave Cain 2016-03-30 09:50:25 EDT
Looks like this is in the OSP8 Beta9 from what I can tell.  Will this make GA of OSP8?
Comment 15 Mike Burns 2016-03-30 10:08:48 EDT
This patch was merged and is in OSP8
Comment 18 errata-xmlrpc 2016-04-07 17:39:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.