Bug 1259015 - persistent interface names for virtio interfaces
persistent interface names for virtio interfaces
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd (Show other bugs)
7.2
All Linux
unspecified Severity urgent
: rc
: ---
Assigned To: systemd-maint
qe-baseos-daemons
Jana Heves
:
Depends On:
Blocks: 1252514
  Show dependency treegraph
 
Reported: 2015-09-01 14:41 EDT by Harald Hoyer
Modified: 2015-11-19 10:08 EST (History)
12 users (show)

See Also:
Fixed In Version: systemd-219-13.el7
Doc Type: Release Note
Doc Text:
Enable virtio network device renaming This update adds a new persistent naming scheme for the virtio driver, which enables virtio network device renaming. To enable this feature in Red Hat Enterprise Linux 7.2, add the "net.ifnames=1" kernel parameter while booting.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 10:08:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Harald Hoyer 2015-09-02 08:42:14 EDT
With the patch in place, qemu instances with virtio network interfaces will gain the ID_NET_NAME_PATH attributes, and will be renamed according to their PCI slot.
Comment 9 Lukáš Nykrýn 2015-10-09 08:59:27 EDT
Let's make this new behavior opt-in:

https://github.com/lnykryn/systemd-rhel/commit/727e60797beff565a2f1d16bd63aa6bb7b5a787f
Comment 10 errata-xmlrpc 2015-11-19 10:08:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2092.html

Note You need to log in before you can comment on or make changes to this bug.