Bug 125903 - Ability to set debug level for yum.cron (changing yum.cron directly has issues)
Summary: Ability to set debug level for yum.cron (changing yum.cron directly has issues)
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-13 17:15 UTC by Adam Gibson
Modified: 2014-01-21 22:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-01 19:39:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Gibson 2004-06-13 17:15:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
It would be nice to be able to have a crondebug level in
/etc/sysconfig/yum that could be used to set the debug level for yum
when the yum.cron script gets run instead of always using level 0
where nothing gets logged when packages get updated.  I prefer to not
get cron.daily yum emails unless a package is updated.  By setting the
debug level to 1, I get the desired output.

If I just edit yum.cron to change the debug level to 1 so that I get
cron.daily yum reports of updated packages, the next time yum gets
updated I am pretty sure there will be problems because cron.daily is
set as a config file so it will get duplicated when yum gets updated
to a new version(yum.cron.rpmsave or yum.cron.rpmnew).  That would
cause 2 yum jobs to get done and probably not in the order that you
would want.  

The best way around that seems to be to have a setting in
/etc/sysconfig/yum for tweaking the yum.cron file for crondebuglevel.
 Maybe some other people would have a reason to adjust the error level
to, so maybe at the same time make that adjustable from
/etc/sysconfig/yum?

I currently set my systems to never update yum so that the yum file
does not get duplicated in case of a new version of yum is released,
but it would be nice to have a better solution for that.

Version-Release number of selected component (if applicable):
yum-2.0.7-1.1

How reproducible:
Always

Steps to Reproduce:
1. edit yum.cron
2. create an update for yum
3. update the yum rpm on the system
4. notice that now there are two scrips in /etc/cron.daily/ for yum
which means it will get run twice and not neccessarily in the order
that the user would want.

Actual Results:  2 yum.cron* files exist on the system after upgrading
the yum rpm with an edited yum.cron file.

Expected Results:  Not needing to edit the yum.cron file directly to
tweak the debug and error levels.

Additional info:

Comment 1 Seth Vidal 2004-11-01 19:39:07 UTC
errors and results get logged in -d0 -e0 as in the yum cron job.

look in /var/log/yum.log.




Note You need to log in before you can comment on or make changes to this bug.