Bug 125905 - Kernel problem with KDSKBENT which also causes problems for Xorg
Kernel problem with KDSKBENT which also causes problems for Xorg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-13 13:48 EDT by Jonathan Underwood
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 14:19:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2004-06-13 13:48:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
kernel-2.6.6-1.427 causes problems with Xorg - erratic and ill defined
mouse behaviour being most noticeable. This seems to be related to the
following message:

KDSKBENT: Invalid argument
failed to bind key 255 to value 814

This message appears on the terminal whenever changing runlevel and
when shutting down. From a quick google, this seems to be an SElinux
issue, though I am, and always have, run in permissive mode. This is
on a very fresh install of FC2.

This problem is NOT present in kernel-2.6.5-1.358

In X, the mouse behaviour is not reproducible, sometimes it happens,
sometimes not, but it manifests itself as an inabilty to switch focus
with the mouse, the mouse cursor doesn't change from the text entry
bar to the pointer etc.

This bug renders the system unuseable, forcing a reboot and use of an
earlier kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.427

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel-2.6.6-1.427
2. To see message, change init level
3.
    

Actual Results:  KDSKBENT: Invalid argument
failed to bind key 255 to value 814


Expected Results:  No errors 

Additional info:
Comment 1 Dawid Gajownik 2004-06-13 17:31:53 EDT
On my machine I have this warning:

KDSKBENT: Invalid argument
failed to bind key 255 to value 2707

kernel-2.6.6-1.424 doesn't have this bug.

I didn't have such a big problem with mouse, only my middle button was
acting weird - it was making two 'clicks', not one. For example, in
Mozilla, it was closing two opened tabs, not one (realy annoying).
Unfortunatelly, I don't remember when it exactly started (few days
ago, I presume), because most of the time mouse works correctly.
Comment 2 Stephen Smalley 2004-06-15 10:26:02 EDT
I'm not clear that this is SELinux-related.  Try booting with
selinux=0 or setting SELINUX=disabled in /etc/sysconfig/selinux and
see if the problem still occurs.
Comment 3 sangu 2004-06-16 08:43:53 EDT
please see : https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=125133

Comment 4 sangu 2004-06-16 12:10:08 EDT
This problem may be fixed in kernel-2.6.7-1.437

( http://people.redhat.com/arjanv/2.6/RPMS.kernel/ )
Comment 5 Dawid Gajownik 2004-06-16 15:37:47 EDT
kernel-2.6.7-1.437 works for me :-)

And sorry for misleading you: problem with my mouse is hardware issue
:( I ran today WinXP and problem with middle button reappeared :/
Comment 6 Jonathan Underwood 2004-06-21 14:19:30 EDT
Good news:

The KDSKBENT messages have disappeared in kernel 2.6.6-1.435

This alone did not fix the problem with the mouse. Having looked at
other bug reports, and noting that the mouse is a USB mouse, I
disabled legacy USB support in the Bios, and now all is well. So I
think the KDSKBENT messages, although being a bug, did not cause the
mouse problems - that's a USB bug/feature. Not sure which. I haven't
changed the status of the bug, as I'm not entirely sure which
resolution is appropriate - please change as you see fit.
Comment 7 sangu 2004-06-27 22:06:18 EDT
This problem happens again in kernel-2.6.7-1.457.
Comment 8 P Jones 2004-07-04 09:08:38 EDT
Just want to add that on a fresh install of FC2 with all available
updates to date, which includes kernel 2.6.6-1.435.2.3, I get the
KDSKBENT error. If I boot with the original kernel and the kernel just
previous to the current one, I don't get the error.

Note You need to log in before you can comment on or make changes to this bug.