Bug 1259060 - Appstream data is outdated and cannot be validated.
Appstream data is outdated and cannot be validated.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: appstream-data (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 17:10 EDT by Johan Vromans
Modified: 2015-09-01 17:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-01 17:14:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan Vromans 2015-09-01 17:10:34 EDT
Description of problem:

Appstream data is outdated and cannot be validated.

Version-Release number of selected component (if applicable):

22-8

How reproducible:

Always

Steps to Reproduce:
1. Install appstream (current version is 0.8.0)
2. apply appstream-validate to e.g. /usr/share/appdata/evince.appdata.xml

Actual results:

E: [<root>] Your file is in a legacy AppStream format, which can not be validated. Please migrate it to spec version 0.6 or above.
Validation failed.

Expected results:

Validation results.

Additional info:

Almost all of the currently supplied appinfo data is outdated and cannot be validated.
Comment 1 Kalev Lember 2015-09-01 17:14:54 EDT
Please use 'appstream-util validate-relax /usr/share/appdata/evince.appdata.xml' for validating appdata that goes in Fedora packages as per https://fedoraproject.org/wiki/Packaging:AppData guidelines. The files pass just fine.

Note You need to log in before you can comment on or make changes to this bug.