Bug 1259104 - Crash when zip file is modified while being used
Crash when zip file is modified while being used
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Andrew John Hughes
Lukas Zachar
:
Depends On:
Blocks: 1172231 1271375
  Show dependency treegraph
 
Reported: 2015-09-01 20:20 EDT by James Livingston
Modified: 2016-05-10 16:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: java-1.6.0-openjdk-1.6.0.37-1.13.9.5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:30:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Icedtea Bugzilla 363 None None None Never
Red Hat Knowledge Base (Solution) 65104 None None None Never
openjdk bug system JDK-4425695 None None None Never

  None (edit)
Description James Livingston 2015-09-01 20:20:32 EDT
The JDK memory maps zip files (including jars) into memory, which can cause a crash if they are modified.

OpenJDK 7 and Oracle JDK 6 support a sun.zip.disableMemoryMapping system property which disabled the memory mapping, working around the problem. It would be good to backport support for that to OpenJDK 6, to allow customers to work around the issue.
Comment 2 Deepak Bhole 2015-09-02 09:57:26 EDT
Re-assigning to Andrew Hughes for backport once aph has ackd.

Andrew (Haley), any objections to having this backported?
Comment 10 errata-xmlrpc 2016-05-10 16:30:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0788.html

Note You need to log in before you can comment on or make changes to this bug.