Bug 125914 - XSane does not recognize scanner: Epson Perfection 1640 SU
XSane does not recognize scanner: Epson Perfection 1640 SU
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xsane (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-13 18:46 EDT by Joe Chesak
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 09:30:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Chesak 2004-06-13 18:46:34 EDT
Description of problem:
I performed a fresh install of Redhat Enterprise WS, with a USB
scanner plugged in and turned on.  Xsane does not recognize the
scanner Epson Perfection 1640 SU.  When I attempt to configure the
scanner I get the folloing message "no devices available".

Version-Release number of selected component (if applicable):
Redhat Enterprise WS version 3

How reproducible:
100%

Steps to Reproduce:
1. In Redhat GUI click Main Menu > Graphics > Scanning > Accept. 
Error message: "no devices available".
2. Then at a console type "sane-find-scanner".  The scanner is found
but not recognized.  Here's the resulting message:


Actual results:
----------
# sane-find-scanner
 
  # No SCSI scanners found. If you expected something different, make
sure that
  # you have loaded a SCSI driver for your SCSI adapter.
 
found USB scanner (vendor=0x04b8, product=0x010a) at /dev/usb/scanner0
found USB scanner (vendor=0x04b8 [EPSON], product=0x010a
[Perfection1640]) at libusb:002:005
  # A USB device was detected. This program can't be sure if it's really
  # a scanner. If it is your scanner, it may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.
 
  # Scanners connected to the parallel port or other proprietary ports
can't be
  # detected by this program.


Expected results:
Recognition and automatic configuration of scanning device.

Additional info:
Comment 2 Pete Zaitcev 2004-06-15 14:10:02 EDT
Not a bug.

Scanners do not have a device class, they are always determinded
by the vendor:product ID. Because of this, it's a losing battle
to add those. Use options vendor= and product= in /etc/modules.conf.

N.B. Contemporary SANE backends work through libusb and have their
own vendor:product lists. The kernel scanner driver will be
discontinued in the next release of the RHEL (already discontinued
in FC2).
Comment 3 Suzanne Hillman 2004-06-16 09:30:08 EDT
Closed NOTABUG as per comment #2

Note You need to log in before you can comment on or make changes to this bug.