Bug 1259174 - Smart variables values always shows default in host edit form
Smart variables values always shows default in host edit form
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Beta
: --
Assigned To: Tomer Brisker
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 02:59 EDT by Tomer Brisker
Modified: 2016-07-27 04:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 04:55:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 7840 None None None 2016-04-22 11:42 EDT

  None (edit)
Description Tomer Brisker 2015-09-02 02:59:55 EDT
When editing a host in the "Parameters" tab under "Puppet class" smart variables always show default value even when there is an override for the variable that matches the host.
The host's yaml show's the correct value
Comment 1 Tomer Brisker 2015-09-02 02:59:56 EDT
Created from redmine issue http://projects.theforeman.org/issues/7840
Comment 3 Bryan Kearney 2015-09-02 04:04:26 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/7840 has been closed
-------------
Anonymous
Applied in changeset commit:33eca4dfec4949308aa265420b963cd80c5f7d13.
Comment 6 jcallaha 2016-04-07 13:51:35 EDT
Verified in Satellite 6.2 Beta snap 6 Compose 2. Overriden values are shown.
Comment 8 errata-xmlrpc 2016-07-27 04:55:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500

Note You need to log in before you can comment on or make changes to this bug.