Bug 1259175 - dnf distro-sync unexpectedly removes packages
dnf distro-sync unexpectedly removes packages
Status: CLOSED DUPLICATE of bug 1244175
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 03:01 EDT by Daniel Mach
Modified: 2015-10-19 05:03 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 05:03:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2015-09-02 03:01:39 EDT
I updated f22 to f23 by running:
dnf distro-sync --releasever=23

This made rpmfusion repos unavailable, because they do not exist for $releasever 23

dnf knows that some repos are broken and disables them.
dnf distro-sync removes all packages that are not found in repos.

Imagine situation when a server with yum repos has an outage.
dnf disables the repo(s) and distro-sync removes packages.

I'd like dnf not to remove packages by default and introduce an option to allow removing extra packages or re-use --allowerasing.
Using -x option to manually exclude packages from distro-sync doesn't help.
Comment 1 Radek Holy 2015-09-07 07:19:55 EDT
Thank you for the report. The distro-sync way of upgrading Fedora is not supported but considering how often repositories are not available, it might be useful in other cases as well. We'll take a look.
Comment 2 Honza Silhan 2015-10-19 05:03:59 EDT

*** This bug has been marked as a duplicate of bug 1244175 ***

Note You need to log in before you can comment on or make changes to this bug.