Bug 1259193 - Missing dv-bom and teiid-odata artifacts.
Missing dv-bom and teiid-odata artifacts.
Status: CLOSED NOTABUG
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Distribution (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alex Szczuczko
Juraj Duráni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 03:30 EDT by Juraj Duráni
Modified: 2015-09-10 01:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-09 11:49:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juraj Duráni 2015-09-02 03:30:08 EDT
There are missing artifacts in the repo:

org.jboss.teiid:teiid-odata:8.7.1.6_2-redhat-5
org.jboss.dv.component.management:dv-bom:2.2.0.redhat-6
Comment 1 Alex Szczuczko 2015-09-08 11:02:49 EDT
Juraj,

I'm not sure if dv-bom is an artifact that exists anywhere, at least I can't find it. I thought you might mean dv-dependency-management-all, which effectively is the DV BOM, but that's present. Could you please clarify why dv-bom is missing?

Thanks.
Comment 2 Juraj Duráni 2015-09-09 01:19:29 EDT
Alex,

maven repository contains artifact org.jboss.dv.component.management:dv-component-management-aggregation:2.2.0.redhat-6. It is "pom" project and contains 2 modules: dv-parent, dv-bom. Artifact dv-parent is present, but dv-bom not. I thought that both of them should be present in repository.
Comment 3 Alex Szczuczko 2015-09-09 04:32:55 EDT
Juraj,

Ok, I do see the <module>dv-bom</module> definition there. I think the confusion is because that module's artifactId doesn't follow convention, and is called something other than the module name.

The pom located in the dv-bom/ subdirectory[1] has an artifactId of dv-dependency-management-aggregation (note: not the same as dv-component-management-aggregation), and is present in the repo.

So dv-bom is just the module name, not the ID of any artifact. I wasn't aware that this was possible, so I'm just as surprised as you.

[1] https://code.engineering.redhat.com/gerrit/gitweb?p=soa/soa-component-management.git;a=tree;f=src/main/resources/bom/dv-bom;h=c3fcdc9db629443dc9be71f106290d0ce7846e65;hb=refs/heads/jb-dv-6.2

[2] http://download.eng.bos.redhat.com/brewroot/repos/jb-dv-6.2-build/latest/maven/org/jboss/dv/component/management/dv-dependency-management-aggregation/
Comment 4 Juraj Duráni 2015-09-09 05:45:35 EDT
Alex,

I can confirm that dv-dependency-management-aggregation is present in the repo. Modules which are defined as modules of "dv-bom" do not follow convention either ("dv-dependency-management-supported" vs. "supported").
I think we can close the "dv-bom" part of this issue.

What about the second part ("teiid-odata")?
Comment 5 Alex Szczuczko 2015-09-09 05:55:48 EDT
teiid-odata should be there, but doesn't seem to have been processed correctly by the repo generator. Still working on getting it included.
Comment 6 Alex Szczuczko 2015-09-09 09:30:09 EDT
Juraj,

After investigating, the reason teiid-odata wasn't being included was that it is a war type artifact. Wars are specifically excluded from the repo, so it's expected that teiid-odata is missing.

I've double checked with Van, and he confirms that the teiid-odata war isn't needed.

Since both missing artifacts have resulted in no changes, I'll close this as NOTABUG. Is that ok with you?
Comment 7 Alex Szczuczko 2015-09-09 11:49:41 EDT
Since the hand-over deadline is imminent, I will close this bug now.
Comment 8 Juraj Duráni 2015-09-10 01:31:15 EDT
It is ok with me.

Note You need to log in before you can comment on or make changes to this bug.