Bug 1259205 - qemu with -vga qxl can't display the mouse pointer
qemu with -vga qxl can't display the mouse pointer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 04:02 EDT by Peng Wu
Modified: 2017-03-24 13:51 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-24 13:51:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peng Wu 2015-09-02 04:02:21 EDT
Description of problem:
When launch qemu-kvm from terminal with -vga qxl, the mouse pointer disappeared.
But with -vga vmware, the mouse appears okay.

Version-Release number of selected component (if applicable):
qemu-2.3.1-1.fc22

How reproducible:
Launch qemu-kvm by using the following command:
qemu-kvm -m 1024 -monitor stdio -vga qxl -net nic -net user Fedora22.qcow2


Steps to Reproduce:
1. Install Fedora 22/23 by using qemu-img and qemu-kvm;
2. Start Gnome Display Manager;

Actual results:
With full screen, the mouse disappears.

Expected results:
With full screen, the mouse appears.

Additional info:
With -vga vmware, the mouse works okay.

qemu-kvm -m 1024 -monitor stdio -vga vmware -net nic -net user Fedora22.qcow2
Comment 1 Cole Robinson 2016-05-02 16:24:29 EDT
Sorry for the lack of response. Do you still see this on an f23+ host with f23+ VM?
Comment 2 Peng Wu 2016-05-03 02:15:21 EDT
I tried on F23 host with F23 VM, the bug still exists.
Comment 3 Cole Robinson 2016-05-14 11:45:09 EDT
Thanks, I can reproduce. This seems to be related to relative mouse handling, using -usb tablet will 'fix' it and give better mouse interaction anyways.

rhel6 guest works as expected, so maybe this is a qxl or modesetting driver regression. -vga std is also affected
Comment 4 Cole Robinson 2017-03-24 13:51:29 EDT
With F25 qemu and F25 guest this doesn't seem to be an issue anymore, with that minimal command line. I think F25 guest + vmmouse is better coordinated now, since using vmport=off gives crappy behavior again (but vmmouse=on is the qemu default)

Note You need to log in before you can comment on or make changes to this bug.