Bug 1259215 - vdsm fails to create volume for VMs with disks that contain russian names
vdsm fails to create volume for VMs with disks that contain russian names
Status: CLOSED DUPLICATE of bug 1249130
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.3
x86_64 Linux
unspecified Severity low
: ---
: 3.5.5
Assigned To: Idan Shaby
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 04:20 EDT by Igor Kroshkin
Modified: 2016-02-10 12:30 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 09:48:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Kroshkin 2015-09-02 04:20:48 EDT
Description of problem:

If Russian characters are used as Virtual Machine name, a VM is either can not be created or started.

Version-Release number of selected component (if applicable):
RHEL 7.1 (default installation) as hypervisor
RHEV-M 3.5.3.1-1.4.el6ev deployed as self-hosted engine

How reproducible:
Create a VM with Russian letters. The creation process fails on disk creation stage if Russian characters are used in Disk Name Field. If manually change the Russian characters to English in Disk Name Field, a VM will be created, but can not be started.

Steps to Reproduce:
1. Create a new VM with Russian characters in Name Field. 
2. The creation process fails on disk creating stage with Russian letters.
3. If manually change Disk Name Field to English letters, a VM will be created, but can not be started.

Actual results:
A VM can not be created and started if Russian characters are used in VM Name Field. 

Expected results:
A VM can be created if Russian characters are used in VM Name and Disk Name fields.

Additional info:
Error messages if Russian characters are used in VM Name and Disk Name fields:
2015-08-31 04:44:03,802 INFO [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-23) [58150bb1] Correlation ID: 613a0c7c, Job ID: 2567f4bf-0647-40ec-ba54-e5d1494187b1, Call Stack: null, Custom Event ID: -1, Message: Add-Disk operation of РусВирт_Disk1 was initiated on VM РусВирт by admin@internal.
2015-08-31 04:44:03,803 INFO [org.ovirt.engine.core.bll.tasks.SPMAsyncTask] (ajp-/127.0.0.1:8702-23) [58150bb1] BaseAsyncTask::startPollingTask: Starting to poll task 7608c008-8766-4631-a00e-1de3ac331a6c.
2015-08-31 04:44:13,111 INFO [org.ovirt.engine.core.bll.tasks.AsyncTaskManager] (DefaultQuartzScheduler_Worker-9) [d627b7d] Polling and updating Async Tasks: 1 tasks, 1 tasks to poll now
2015-08-31 04:44:13,116 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.HSMGetAllTasksStatusesVDSCommand] (DefaultQuartzScheduler_Worker-9) [d627b7d] Failed in HSMGetAllTasksStatusesVDS method
2015-08-31 04:44:13,116 INFO [org.ovirt.engine.core.bll.tasks.SPMAsyncTask] (DefaultQuartzScheduler_Worker-9) [d627b7d] SPMAsyncTask:ollTask: Polling task 7608c008-8766-4631-a00e-1de3ac331a6c (Parent Command AddDisk, Parameters Type org.ovirt.engine.core.common.asynctasks.AsyncTaskParameters) returned status finished, result 'cleanSuccess'.
2015-08-31 04:44:13,137 ERROR [org.ovirt.engine.core.bll.tasks.SPMAsyncTask] (DefaultQuartzScheduler_Worker-9) [d627b7d] BaseAsyncTask::logEndTaskFailure: Task 7608c008-8766-4631-a00e-1de3ac331a6c (Parent Command AddDisk, Parameters Type org.ovirt.engine.core.common.asynctasks.AsyncTaskParameters) ended with failure:
-- Result: cleanSuccess
-- Message: VDSGenericException: VDSErrorException: Failed to HSMGetAllTasksStatusesVDS, error = Error creating a new volume, code = 205,
-- Exception: VDSGenericException: VDSErrorException: Failed to HSMGetAllTasksStatusesVDS, error = Error creating a new volume, code = 205

Error messages if Russian characters are used in VM Name field only (Disk Name field in English):
2015-08-31 04:39:08,683 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler_Worker-46) [26cbfe44] Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: VM рус_лин is down with error. Exit message: 'ascii' codec can't decode byte 0xd1 in position 67: ordinal not in range(128)
Comment 1 Evgheni Dereveanchin 2015-09-02 04:27:39 EDT
I want to note that I tries to reproduce this with RHEL-H 6 and a VM with a name in Cyrillic is able to start, but only if its disk has a name in Russian.
Comment 2 Allon Mureinik 2015-09-03 09:48:11 EDT

*** This bug has been marked as a duplicate of bug 1249130 ***

Note You need to log in before you can comment on or make changes to this bug.