This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1259225 - Add node of nfs-ganesha not working on rhel7.1
Add node of nfs-ganesha not working on rhel7.1
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: common-ha (Show other bugs)
3.7.3
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Soumya Koduri
: Reopened, Triaged
Depends On: 1259221
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 05:02 EDT by Soumya Koduri
Modified: 2016-06-16 09:34 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1259221
Environment:
Last Closed: 2016-06-16 09:34:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Niels de Vos 2015-09-02 05:42:43 EDT
Please provide a public description of this problem so that everyone in the community can benefit from it.
Comment 2 Soumya Koduri 2015-09-02 07:55:08 EDT
There are couple of issues found here --

1) The secret.pem generated/copied should have restrictive permissions - 600.

2) On RHEL-7 machines, the service manager 'systemd' path was incorrectly compared  with '/usr/sbin/systemctl' instead of '/usr/bin/systemctl' in the HA-script.

3) Also paswordless scp of the config files shall not work if the source and destination node are found to be same. This needs to be fixed as well in the HA script.
Comment 3 Vijay Bellur 2015-09-02 13:46:08 EDT
REVIEW: http://review.gluster.org/12091 (CommonHA: Avoid scp of the config state to the same host) posted (#3) for review on release-3.7 by soumya k (skoduri@redhat.com)
Comment 4 Vijay Bellur 2015-09-02 20:31:38 EDT
COMMIT: http://review.gluster.org/12091 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 07b31a008b59d6c0b06bd17994de85fc56560b38
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Wed Sep 2 17:15:23 2015 +0530

    CommonHA: Avoid scp of the config state to the same host
    
    During add-node, have seen an issue where in scp doesn't work
    if the source and destination host are same. Fixed the same.
    
    Change-Id: I33fc18ff39e54ced277f94afef7a11a22c9ccce0
    BUG: 1259225
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/12091
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 5 Vijay Bellur 2015-09-03 04:47:33 EDT
COMMIT: http://review.gluster.org/12089 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 8e7ca068720fa6fa50e4746e5b17c305f38171e8
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Wed Sep 2 14:17:55 2015 +0530

    CommonHA: Fix the path of 'systemctl' cmd
    
    'systemctl' command path should be '/usr/bin/sytemctl'.
    Fixed the typo in the HA-script.
    
    Change-Id: Ied9fb85e25646ef00b303e361966e9d1354fe440
    BUG: 1259225
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/12089
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 6 Pranith Kumar K 2015-10-14 06:30:01 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 7 Pranith Kumar K 2015-10-14 06:30:01 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 8 Pranith Kumar K 2015-10-14 06:38:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 9 Pranith Kumar K 2015-10-14 06:38:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 10 Vijay Bellur 2016-03-14 07:45:23 EDT
REVIEW: http://review.gluster.org/13720 (CommonHA: Avoid scp of the config state to the same host) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 11 Vijay Bellur 2016-03-14 07:45:28 EDT
REVIEW: http://review.gluster.org/13721 (CommonHA: Fix the path of 'systemctl' cmd) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 12 Vijay Bellur 2016-03-15 00:25:35 EDT
COMMIT: http://review.gluster.org/13720 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 5154e581ae3424890533bcd71e61e0a6f4a5aa08
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Wed Sep 2 17:15:23 2015 +0530

    CommonHA: Avoid scp of the config state to the same host
    
    During add-node, have seen an issue where in scp doesn't work
    if the source and destination host are same. Fixed the same.
    
    BUG: 1259225
    Change-Id: Ib8fe21b3c95d653c62698310d5390b46a3c6bbf4
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/12091
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-on: http://review.gluster.org/13720
    Tested-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 13 Vijay Bellur 2016-03-15 00:27:07 EDT
COMMIT: http://review.gluster.org/13721 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit bcb3f9ba2b879257192c269ded6d16d29479023a
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Wed Sep 2 14:17:55 2015 +0530

    CommonHA: Fix the path of 'systemctl' cmd
    
    'systemctl' command path should be '/usr/bin/sytemctl'.
    Fixed the typo in the HA-script.
    
    BUG: 1259225
    Change-Id: I0e7fcc1eb74419679d78d4cc61253c6edf23b57b
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/12089
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-on: http://review.gluster.org/13721
    Tested-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 14 Niels de Vos 2016-06-16 09:34:51 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.