Bug 1259231 - kernel 4.2 don't work with akmod-nvidia
kernel 4.2 don't work with akmod-nvidia
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
: 1259947 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 05:10 EDT by dominique
Modified: 2015-09-07 12:35 EDT (History)
10 users (show)

See Also:
Fixed In Version: 4.2.0-300.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-07 12:35:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
flush.patch (374 bytes, patch)
2015-09-02 05:10 EDT, dominique
no flags Details | Diff

  None (edit)
Description dominique 2015-09-02 05:10:00 EDT
Created attachment 1069306 [details]
flush.patch

I test the F23 release and with that akmod-nvidia don't work and don't build kmod-nvidia.
I have this error : 

2015/09/01 18:26:08 akmodsbuild: FATAL: modpost: GPL-incompatible module
nvidia.ko uses GPL-only symbol 'flush_workqueue'

I search on web and find this : https://forums.geforce.com/default/topic/849487/geforce-drivers/linux-v4-2-uses-gpl-only-symbol-flush_workqueue-/

I rebuild kernel 4.2.0-1.fc23.x86_64 with the patch and that work.

Can you add the patch to the next kernel ?
Comment 1 leigh scott 2015-09-02 06:21:20 EDT
Please backport this commit to the f23 and rawhide branches 

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=ad7b1f841f8a54c6d61ff181451f55b68175e15a
Comment 2 Josh Boyer 2015-09-02 08:20:51 EDT
(In reply to leigh scott from comment #1)
> Please backport this commit to the f23 and rawhide branches 
> 
> http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/
> ?id=ad7b1f841f8a54c6d61ff181451f55b68175e15a

That commit is:

1) Over two years old
2) Contained in Linux v3.10
3) Already in all Fedora releases
4) Doesn't have anything to do with the symbol the original reporter noticed.
Comment 3 Josh Boyer 2015-09-02 08:26:15 EDT
(In reply to dominique from comment #0)
> Created attachment 1069306 [details]
> flush.patch
> 
> I test the F23 release and with that akmod-nvidia don't work and don't build
> kmod-nvidia.
> I have this error : 
> 
> 2015/09/01 18:26:08 akmodsbuild: FATAL: modpost: GPL-incompatible module
> nvidia.ko uses GPL-only symbol 'flush_workqueue'
> 
> I search on web and find this :
> https://forums.geforce.com/default/topic/849487/geforce-drivers/linux-v4-2-
> uses-gpl-only-symbol-flush_workqueue-/
> 
> I rebuild kernel 4.2.0-1.fc23.x86_64 with the patch and that work.
> 
> Can you add the patch to the next kernel ?

No.  For the following reasons:

1) It has no signed-off-by line.
2) It is entirely counter to upstream.
3) The flush_workqueue function has been EXPORT_SYMBOL_GPL since 2006.  This is not a new change in the upstream kernel.

So either the nvidia module started using this function recently, or some other function the nvidia module uses calls this instead.  Since we can't tell because the nvidia module is proprietary, the best you can do is report this to nvidia and possibly upstream.

Fedora is not going to change anything here.
Comment 4 leigh scott 2015-09-02 09:16:34 EDT
(In reply to Josh Boyer from comment #3)
> (In reply to dominique from comment #0)
> > Created attachment 1069306 [details]
> > flush.patch
> > 
> > I test the F23 release and with that akmod-nvidia don't work and don't build
> > kmod-nvidia.
> > I have this error : 
> > 
> > 2015/09/01 18:26:08 akmodsbuild: FATAL: modpost: GPL-incompatible module
> > nvidia.ko uses GPL-only symbol 'flush_workqueue'
> > 
> > I search on web and find this :
> > https://forums.geforce.com/default/topic/849487/geforce-drivers/linux-v4-2-
> > uses-gpl-only-symbol-flush_workqueue-/
> > 
> > I rebuild kernel 4.2.0-1.fc23.x86_64 with the patch and that work.
> > 
> > Can you add the patch to the next kernel ?
> 
> No.  For the following reasons:
> 
> 1) It has no signed-off-by line.
> 2) It is entirely counter to upstream.
> 3) The flush_workqueue function has been EXPORT_SYMBOL_GPL since 2006.  This
> is not a new change in the upstream kernel.
> 

Yes it is!

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/kernel/workqueue.c?id=37b1ef31a568fc02e53587620226e5f3c66454c8

> So either the nvidia module started using this function recently, or some
> other function the nvidia module uses calls this instead.  Since we can't
> tell because the nvidia module is proprietary, the best you can do is report
> this to nvidia and possibly upstream.
> 

Nvidia changed nothing!

> Fedora is not going to change anything here.

No change there then!
Comment 5 Josh Boyer 2015-09-02 09:23:20 EDT
https://git.kernel.org/cgit/linux/kernel/git/tj/wq.git/commit/?h=for-4.3&id=1dadafa86a779884f14a6e7a3ddde1a57b0a0a65 is the queued solution.  I've kindly poked them to see if it can be included in the stable 4.2 kernel.  If they do, then Fedora will inherit it naturally.
Comment 6 leigh scott 2015-09-02 09:29:07 EDT
(In reply to Josh Boyer from comment #5)
> https://git.kernel.org/cgit/linux/kernel/git/tj/wq.git/commit/?h=for-4.
> 3&id=1dadafa86a779884f14a6e7a3ddde1a57b0a0a65 is the queued solution.  I've
> kindly poked them to see if it can be included in the stable 4.2 kernel.  If
> they do, then Fedora will inherit it naturally.

Thank you for looking into this issue.
Comment 7 Laura Abbott 2015-09-03 17:51:14 EDT
*** Bug 1259947 has been marked as a duplicate of this bug. ***
Comment 8 dominique 2015-09-06 00:36:19 EDT
kernel-4.2.0-300.fc23 from koji : https://koji.fedoraproject.org/koji/buildinfo?buildID=682842
solve for me the problem.

Thank.
Comment 9 Fedora Update System 2015-09-06 17:57:08 EDT
kernel-4.2.0-300.fc23, linux-firmware-20150904-56.git6ebf5d57.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update kernel linux-firmware'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15131
Comment 10 Fedora Update System 2015-09-07 12:35:08 EDT
kernel-4.2.0-300.fc23, linux-firmware-20150904-56.git6ebf5d57.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.