Bug 1259244 - VmPool error always return "No available VMs in the VM-Pool"
VmPool error always return "No available VMs in the VM-Pool"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Shahar Havivi
sefi litmanovich
:
: 1090926 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 05:29 EDT by Shahar Havivi
Modified: 2016-04-19 21:31 EDT (History)
10 users (show)

See Also:
Fixed In Version: 3.6.0-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:31:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45631 master MERGED VmPool error always return "No available VMs in the VM-Pool" Never
oVirt gerrit 45691 ovirt-engine-3.6 MERGED VmPool error always return "No available VMs in the VM-Pool" Never

  None (edit)
Description Shahar Havivi 2015-09-02 05:29:38 EDT
Description of problem:
On an error in VmPool engine returns the same general error: 
"Cannot ${action} ${type}. There are no available VMs in the VM-Pool."

Tested when no sufficient memory and no disk to run from with the same results
Comment 1 Shahar Havivi 2015-09-07 08:31:41 EDT
*** Bug 1090926 has been marked as a duplicate of this bug. ***
Comment 2 sefi litmanovich 2015-11-15 08:55:03 EST
Verified with rhevm-3.6.0.3-0.1.el6.noarch.

Created a large vm pool, defined more prestarted vms than host memory can handle.
several vms started, at the point where host memory wasn't sufficient got an error:
"Failed to complete starting of VM error_pool_test_05."
and not the mentioned error in bug description.

please let me know if there's a specific flow you'd like me to test for this bz.
Comment 3 Shahar Havivi 2015-11-15 08:57:48 EST
(In reply to sefi litmanovich from comment #2)
yes its ok

Note You need to log in before you can comment on or make changes to this bug.