Bug 1259246 - [7.1.z] Collect plotnetcfg output.
[7.1.z] Collect plotnetcfg output.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: sos (Show other bugs)
7.0 (Kilo)
x86_64 Linux
high Severity high
: z2
: 7.0 (Kilo)
Assigned To: Lee Yarwood
Prasanth Anbalagan
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 05:30 EDT by Lee Yarwood
Modified: 2015-10-08 08:22 EDT (History)
13 users (show)

See Also:
Fixed In Version: sos-3.2-16.el7ost.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 08:22:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Yarwood 2015-09-02 05:30:53 EDT
The plotnetcfg tool [1] has recently been packaged for RHEL OSP 7 [1]
and provides a useful method for visualising complex host
network toplogies. In the case of Openstack hosts this includes
Openvswitch devices, flows etc.

The resulting file can be used to generate a PDF visualising
this with the following command :

`cat plotnetcfg | dot -Tpdf > output.pdf`

[1] https://github.com/jbenc/plotnetcfg
Comment 3 Nir Yechiel 2015-09-24 09:46:39 EDT
Hi Lee, 

Who is responsible for the sos component? How can we make sure this is included with RHEL OSP 7 release?

Thanks,
Nir
Comment 4 Lee Yarwood 2015-09-25 06:19:31 EDT
(In reply to Nir Yechiel from comment #3)
> Hi Lee, 
> 
> Who is responsible for the sos component? How can we make sure this is
> included with RHEL OSP 7 release?

Hello Nir, apologies for the delay, I am responsible for this fork of the RHEL sos package. This change is now merged and built into `sos-3.2-16.el7ost.5`.
Comment 9 Prasanth Anbalagan 2015-10-05 08:42:46 EDT
Verified as follows,

Version
========

[root@XXX /]# yum list installed | grep rdomanager
python-rdomanager-oscplugin.noarch   0.0.10-7.el7ost         @rhelosp-7.0-director-puddle
[root@XXX /]# 
[root@XXX /]# yum list installed | grep plotnet
plotnetcfg.x86_64                    0.3-1.el7ost            @rhelosp-7.0-puddle
[root@XXX /]# 

Logs
=====

[root@XXX /]# ssh XXXX plotnetcfg
// generated by plotnetcfg v0.3 on Mon Oct  5 15:37:47 2015
digraph {
node [shape=box]
"/lo" [label="lo\nX.X.X.X/X\n::1/128",style=filled,fillcolor="darkolivegreen1"]
"/eno1" [label="eno1 (igb)",style=filled,fillcolor="pink"]
"/eno2" [label="eno2 (igb)",style=filled,fillcolor="pink"]
"/enp5s0f0" [label="enp5s0f0 (ixgbe)\nX.X.X.X/X\nfe80::a236:9fff:fe47:2b9c/64",style=filled,fillcolor="darkolivegreen1"]
"/enp5s0f1" [label="enp5s0f1 (ixgbe)",style=filled,fillcolor="pink"]
"/ovs-system" [label="ovs-system (openvswitch)",style=filled,fillcolor="grey"]
"/br-ctlplane" [label="br-ctlplane (openvswitch)\nX.X.X.X/X\nX.X.X.X/X\nX.X.X.X/X\nfe80::a236:9fff:fe47:2b9e/64",style=filled,fillcolor="darkolivegreen1"]
"/br-int" [label="br-int (openvswitch)",style=filled,fillcolor="grey"]
"//ovs:br-int//int-br-ctlplane" [label="int-br-ctlplane\ntype: patch",style=dotted]
"//ovs:br-ctlplane//phy-br-ctlplane" [label="phy-br-ctlplane\ntype: patch",style=dotted]
subgraph "cluster_qdhcp-05cdac6a-12f3-41ae-90bd-b872dddb2dec" {
label="qdhcp-05cdac6a-12f3-41ae-90bd-b872dddb2dec"
fontcolor="black"
"qdhcp-05cdac6a-12f3-41ae-90bd-b872dddb2dec/lo" [label="lo\nX.X.X.X/X\n::1/128",style=filled,fillcolor="darkolivegreen1"]
"qdhcp-05cdac6a-12f3-41ae-90bd-b872dddb2dec/tap4a44082a-7d" [label="tap4a44082a-7d (openvswitch)\ntype: internal\nX.X.X.X/X\nfe80::f816:3eff:fe58:3f1/64",style=filled,fillcolor="darkolivegreen1"]
}
"/enp5s0f1" -> "/br-ctlplane"
"//ovs:br-int//int-br-ctlplane" -> "/br-int"
"//ovs:br-ctlplane//phy-br-ctlplane" -> "/br-ctlplane"
"//ovs:br-ctlplane//phy-br-ctlplane" -> "//ovs:br-int//int-br-ctlplane" [dir=none]
"qdhcp-05cdac6a-12f3-41ae-90bd-b872dddb2dec/tap4a44082a-7d" -> "/br-int" [label="tag 1"]
}


[root@XXX /]# ssh XXX plotnetcfg | dot -Tpdf > output.pdf
[root@XXX /]# ls -l output.pdf 
-rw-r--r--. 1 root root 17653 Oct  5 15:34 output.pdf
[root@XXX /]#
Comment 11 errata-xmlrpc 2015-10-08 08:22:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1875

Note You need to log in before you can comment on or make changes to this bug.