Bug 1259282 - vdsm rpms are built with wrong prefix
vdsm rpms are built with wrong prefix
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-3.6.0-rc
: 4.17.8
Assigned To: Anton Marchukov
Jiri Belka
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 07:04 EDT by Sandro Bonazzola
Modified: 2016-02-10 07:58 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 07:58:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45079 None None None Never

  None (edit)
Comment 1 Sandro Bonazzola 2015-09-02 07:08:34 EDT
Moving to amarchuk since he's infra owner this week
Comment 2 Anton Marchukov 2015-09-02 08:00:52 EDT
We added the flags to configure, but for some reason with current spec it is then passed to install:

+ install -dDm 0755 /builddir/build/BUILDROOT/vdsm-4.16.26-0.fc21.x86_64/usr --sysconfdir=/etc --localstatedir=/var --libdir=/usr/lib64/var/log/vdsm
install: unrecognized option '--sysconfdir=/etc'
Try 'install --help' for more information.
error: Bad exit status from /var/tmp/rpm-tmp.VxOvvS (%install)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.VxOvvS (%install)
Child return code was: 1

http://jenkins.ovirt.org/job/vdsm_3.5_create-rpms-fc21-x86_64_merged/128/artifact/exported-artifacts/build.log
https://gerrit.ovirt.org/#/c/45079/
Comment 3 Anton Marchukov 2015-09-02 12:11:21 EDT
The patch is ready:

1. First https://gerrit.ovirt.org/#/c/45674/ to fix mox extra configure options passing
2. Second sbonazzo change https://gerrit.ovirt.org/#/c/45079/
Comment 4 Red Hat Bugzilla Rules Engine 2015-09-22 03:43:59 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 5 Jiri Belka 2016-01-21 03:54:13 EST
ok, vdsm-4.17.17-6.git37bda50.el7.centos.noarch.rpm

[root@dell-r210ii-04 tmp]# rpm -qlp http://resources.ovirt.org/pub/ovirt-3.6-snapshot/rpm/el7/noarch/vdsm-4.17.17-6.git37bda50.el7.centos.noarch.rpm  | grep /usr/local
[root@dell-r210ii-04 tmp]#

Note You need to log in before you can comment on or make changes to this bug.