This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1259315 - [Docs][director] creating LoadBalancer configuration document by installer when external load balancer is required
[Docs][director] creating LoadBalancer configuration document by installer w...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: 7.0 (Kilo)
Assigned To: Dan Macpherson
Leonid Natapov
: Documentation, FutureFeature, UserExperience
Depends On:
Blocks: 1244032
  Show dependency treegraph
 
Reported: 2015-09-02 08:00 EDT by Ofer Blaut
Modified: 2016-01-24 20:47 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-24 20:47:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ofer Blaut 2015-09-02 08:00:52 EDT
Description of problem:

When HA proxy is not install by rhel-osp-director 
We should create doc with suggested configuration based on the rhel-osp-installer config  

( we might create ha-proxy.cfg any way and convert it to a doc

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ben Nemec 2015-09-02 15:31:00 EDT
"When HA proxy is not install by rhel-osp-director "

I don't think this is even possible today.  While you could theoretically deploy your own loadbalancer and point it at the OpenStack endpoints, OpenStack itself wouldn't know about the vips you assign so it wouldn't be using them anyway.  This sounds like a much larger RFE than just some documentation.
Comment 8 Dan Macpherson 2016-01-24 20:47:42 EST
This doc has been live since last year:

https://access.redhat.com/documentation/en/red-hat-enterprise-linux-openstack-platform/7/external-load-balancing-for-the-overcloud/external-load-balancing-for-the-overcloud

Closing this bug, but feel free to reopen new bug if further changes are required.

Note You need to log in before you can comment on or make changes to this bug.