Bug 1259360 - garbage files created in /var/run/gluster
garbage files created in /var/run/gluster
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
:
Depends On: 1253970
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-09-02 09:13 EDT by Dan Lambright
Modified: 2015-10-30 13:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1253970
Environment:
Last Closed: 2015-10-14 06:29:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Lambright 2015-09-02 09:13:25 EDT
+++ This bug was initially created as a clone of Bug #1253970 +++

garbage files created in /var/run/gluster

--- Additional comment from Dan Lambright on 2015-08-16 03:40:25 EDT ---

Files are of the type promotefile-<pid> and demotefile-<pid>. Every time a new rebalance daemon is started a new pair of files is created, old ones are not necessarily deleted.

--- Additional comment from Anand Avati on 2015-08-16 03:48:04 EDT ---

REVIEW: http://review.gluster.org/11931 (cluster/tier: avoid filling /var/run with tiering files) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-17 05:57:39 EDT ---

REVIEW: http://review.gluster.org/11931 (cluster/tier: avoid filling /var/run with tiering files) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-27 13:14:29 EDT ---

REVIEW: http://review.gluster.org/11931 (cluster/tier: avoid filling /var/run with tiering files) posted (#4) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-27 17:28:03 EDT ---

REVIEW: http://review.gluster.org/11931 (cluster/tier: avoid filling /var/run with tiering files) posted (#5) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-08-31 16:36:07 EDT ---

REVIEW: http://review.gluster.org/11931 (cluster/tier: avoid filling /var/run with tiering files) posted (#6) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-09-01 14:33:23 EDT ---

REVIEW: http://review.gluster.org/11931 (cluster/tier: avoid filling /var/run with tiering files) posted (#7) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 1 Pranith Kumar K 2015-10-14 06:29:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 2 Pranith Kumar K 2015-10-14 06:38:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.