Bug 1259403 - perl-Inline-C-0.76-1.fc24 FTBFS: tests fail with recent perl-ExtUtils-MakeMaker
perl-Inline-C-0.76-1.fc24 FTBFS: tests fail with recent perl-ExtUtils-MakeMaker
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: perl-Inline-C (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 10:10 EDT by Petr Pisar
Modified: 2015-09-10 09:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-10 09:42:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-09-02 10:10:34 EDT
perl-Inline-C-0.76-1.fc24 fails to build in F24 because some tests fail:

t/26fork.t ............... ok
#   Failed test 'make test'
#   at t/27inline_maker.t line 60.
# make[1]: Entering directory '/builddir/build/BUILD/Inline-C-0.76/_Inline_27inline_maker.13979/src dir'
# cp Simple.pm blib/lib/Math/Simple.pm
# "/usr/bin/perl" -Mblib -MInline=NOISY,_INSTALL_ -MMath::Simple -e"my %A = (modinlname => 'Math-Simple.inl', module => 'Math::Simple'); my %S = (API => \%A); Inline::satisfy_makefile_dep(\%S);" 1.23 blib/arch
# Can't locate Math/Simple.pm in @INC (you may need to install the Math::Simple module) (@INC contains: /builddir/build/BUILD/Inline-C-0.76/_Inline_27inline_maker.13979/src dir/../../blib/arch /builddir/build/BUILD/Inline-C-0.76/_Inline_27inline_maker.13979/src dir/../../blib/lib /builddir/build/BUILD/Inline-C-0.76/blib/lib /builddir/build/BUILD/Inline-C-0.76/blib/arch /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .).
# BEGIN failed--compilation aborted.
# Makefile:829: recipe for target 'Math-Simple.inl' failed
# make[1]: Leaving directory '/builddir/build/BUILD/Inline-C-0.76/_Inline_27inline_maker.13979/src dir'
# make[1]: *** [Math-Simple.inl] Error 2
#   Failed test 'make test'
#   at t/27inline_maker.t line 60.
# make[1]: Entering directory '/builddir/build/BUILD/Inline-C-0.76/_Inline_27inline_maker.13979/src dir'
# cp lib/Boo/Far.pm blib/lib/Boo/Far.pm
# cp lib/Boo/Far/Faz.pm blib/lib/Boo/Far/Faz.pm
# cp lib/Boo.pm blib/lib/Boo.pm
# cp lib/Boo/Far/data.txt blib/lib/Boo/Far/data.txt
# "/usr/bin/perl" -Mblib -MInline=NOISY,_INSTALL_ -MBoo -e"my %A = (modinlname => 'Boo.inl', module => 'Boo'); my %S = (API => \%A); Inline::satisfy_makefile_dep(\%S);" 2.01 blib/arch
# Can't locate Boo.pm in @INC (you may need to install the Boo module) (@INC contains: /builddir/build/BUILD/Inline-C-0.76/_Inline_27inline_maker.13979/src dir/../../blib/arch /builddir/build/BUILD/Inline-C-0.76/_Inline_27inline_maker.13979/src dir/../../blib/lib /builddir/build/BUILD/Inline-C-0.76/blib/lib /builddir/build/BUILD/Inline-C-0.76/blib/arch /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .).
# BEGIN failed--compilation aborted.
# Makefile:835: recipe for target 'Boo.inl' failed
# make[1]: Leaving directory '/builddir/build/BUILD/Inline-C-0.76/_Inline_27inline_maker.13979/src dir'
# make[1]: *** [Boo.inl] Error 2
# Looks like you failed 2 tests of 8.
t/27inline_maker.t ....... 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/8 subtests 

Difference between working and failing build root is:

        perl-ExtUtils-MakeMaker 	7.04-346.fc23 	> 	7.06-2.fc24
	perl-ExtUtils-Command 	1.20-346.fc23 	> 	7.06-2.fc24
	glib2 	2.45.6-1.fc24 	> 	2.45.7-1.fc24
	dnf-plugins-core 	0.1.10-1.fc24 	> 	0.1.11-1.fc24
	libgpg-error 	1.19-2.fc23 	> 	1.20-1.fc24
	gdb 	7.10-15.fc24 	> 	7.10-16.fc24
	python3-dnf-plugins-core 	0.1.10-1.fc24 	> 	0.1.11-1.fc24
Comment 1 Petr Šabata 2015-09-10 09:42:46 EDT
Fixed with the EU::MM 7.08 update.

Note You need to log in before you can comment on or make changes to this bug.