Bug 1259404 - perl-Event-RPC-1.05-5.fc24 FTBFS: Can't open SSL connection to localhost:27816: hostname verification failed at t/04.cnct-auth-ssl-verifypeer-wrongca.t line 54.
perl-Event-RPC-1.05-5.fc24 FTBFS: Can't open SSL connection to localhost:2781...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Event-RPC (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 10:13 EDT by Petr Pisar
Modified: 2015-10-03 13:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Event-RPC-1.05-6.fc24 perl-Event-RPC-1.06-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-03 13:51:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 106874 None None None Never

  None (edit)
Description Petr Pisar 2015-09-02 10:13:38 EDT
perl-Event-RPC-1.05-5.fc24 fails to build in F24 because tests dead-lock:

+ make test
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01.use.t ............................... ok
t/02.cnct.t .............................. ok
t/03.cnct-auth.t ......................... ok
t/04.cnct-auth-ssl-verifypeer-noca.t ..... ok
Can't open SSL connection to localhost:27816: hostname verification failed at t/04.cnct-auth-ssl-verifypeer-wrongca.t line 54.
# Looks like you planned 5 tests but ran 2.
# Looks like your test exited with 255 just after 2.

Difference between working and failing build root is:

        perl-IO-Socket-SSL 	2.016-3.fc23 	> 	2.018-1.fc24
	perl-ExtUtils-MakeMaker 	7.04-346.fc23 	> 	7.06-1.fc24
	perl-ExtUtils-Command 	1.20-346.fc23 	> 	7.06-1.fc24
Comment 1 Fedora Update System 2015-09-07 09:30:35 EDT
perl-Event-RPC-1.05-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15271
Comment 2 Fedora Update System 2015-09-07 14:20:03 EDT
perl-Event-RPC-1.05-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update perl-Event-RPC'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15271
Comment 3 Fedora Update System 2015-09-22 23:56:28 EDT
perl-Event-RPC-1.06-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update perl-Event-RPC'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16334
Comment 4 Fedora Update System 2015-10-03 13:50:41 EDT
perl-Event-RPC-1.06-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.