Bug 1259417 - Named is not properly configured to a public IP after install.
Named is not properly configured to a public IP after install.
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
2.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Timothy Williams
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 10:30 EDT by Eric Rich
Modified: 2016-07-03 20:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 17:51:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Rich 2015-09-02 10:30:08 EDT
Description of problem:
ose-node1.paas.it:   
        OpenShift: Begin running oo-diagnostics.
        OpenShift: oo-diagnostics output - FAIL: prereq_domain_resolves
        OpenShift: oo-diagnostics output -         Application domain does not appear to resolve under
        OpenShift: oo-diagnostics output -         current nameserver configuration. This command:
        OpenShift: oo-diagnostics output -           host -W 5 -t NS 'cloudapps.paas.it'
        OpenShift: oo-diagnostics output -         should have returned the nameserver(s) for cloudapps.paas.it.
        OpenShift: oo-diagnostics output -         Instead, it returned:
        OpenShift: oo-diagnostics output -           cloudapps.paas.it has no NS record
        OpenShift: oo-diagnostics output -
        OpenShift: oo-diagnostics output -         Please check the following to resolve this issue:
        OpenShift: oo-diagnostics output -         * Is CLOUD_DOMAIN=cloudapps.paas.it in node.conf correct?
        OpenShift: oo-diagnostics output -         * Does /etc/resolv.conf have the right nameserver(s)?
        OpenShift: oo-diagnostics output -         * Is your OpenShift domain nameserver running?
        OpenShift: oo-diagnostics output -         * Is the firewall on your nameserver open (udp:53)?
        OpenShift: oo-diagnostics output -         * Does your nameserver respond to queries via dig/host?
        OpenShift: oo-diagnostics output -         Many OpenShift functions may fail without application DNS.
        OpenShift: oo-diagnostics output -
        OpenShift: oo-diagnostics output - FAIL: run_script
        ... 

# oo-diagnostics
FAIL: prereq_dns_server_available
        192.168.110.2 doesn't appear to respond to DNS requests.
        This command:
          host -W 1 example.com. 192.168.110.2
        should have connected to your primary nameserver.
        Instead, it returned:
          ;; connection timed out; trying next origin
;; connection timed out; no servers could be reached

        Please check the following to resolve this issue:
        * Does /etc/resolv.conf have your correct nameserver?
        * Is your nameserver running?
        * Is the firewall on your nameserver open (udp:53)?
        * Can you connect to your nameserver?
        Many OpenShift functions fail without working DNS resolution.

Aborting tests according to prereq_dns_server_available. To run all tests anyway, use the --abortok option.
1 ERRORS

--------------

# head -n 15 /etc/named.conf 

...

options {
        listen-on port 53 { 127.0.0.1; };             ### 
        listen-on-v6 port 53 { ::1; };

-------

This is likely because the node uses 'localhost' for the ssh address and not a public IP. In short this keeps other operations from happening and the install fails. 
  Hosts:
  - console_session_secret: openshift_secret
    load_balancer: N
    openshift_user: demo
    state: validated
    ip_interface: eth0
    mongodb_admin_password: openshift
    broker_auth_priv_key: |
      -----BEGIN RSA PRIVATE KEY-----
      ...
      -----END RSA PRIVATE KEY-----
 
    broker_session_secret: openshift_secret
    mcollective_password: openshift
    user: root
    host: ose-broker.paas.it
    mongodb_broker_password: openshift
    mongodb_broker_user: openshift
    named_ip_addr: 192.168.110.2
    openshift_password: openshift
    mcollective_user: mcollective
    ip_addr: 192.168.110.2
    ssh_host: localhost
    roles:
    - nameserver
    - broker
    - msgserver
    - dbserver
    broker_auth_salt: ZvRGzrPwZMRaGMfS2x9XQ
    mongodb_admin_user: admin
Comment 3 Eric Rich 2016-04-18 17:51:34 EDT
The ask with this is that installed of the named server ensure that 'localhost' use of the sshhost get translated into a public URL. 

This should not happen with https://github.com/openshift/openshift-extras/blob/enterprise-2.2/enterprise/install-scripts/generic/openshift.sh#L2937 because 'any' is used.

Note You need to log in before you can comment on or make changes to this bug.