Bug 1259437 - unformatted and LDL DASD disks not formatted during kickstart installation in text mode
Summary: unformatted and LDL DASD disks not formatted during kickstart installation in...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.2
Hardware: s390x
OS: Linux
high
high
Target Milestone: rc
: 7.3
Assignee: Samantha N. Bueno
QA Contact: Release Test Team
Clayton Spicer
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1186677 1230910 1313485 1366991 1170653 1295926 1355839 1364088
TreeView+ depends on / blocked
 
Reported: 2015-09-02 15:20 UTC by Jan Stodola
Modified: 2016-11-29 11:09 UTC (History)
5 users (show)

(edit)
Formatting DASDs works correctly during a text-based installation

Previously, a bug prevented DASDs from being correctly formatted during a text-based installaton. As a consequence, DASDs that were unformatted or incorrectly formatted had to be manually formatted before use. This bug has been fixed, and the installer can now format DASDs when performing a text-based installation.
Clone Of:
(edit)
Last Closed: 2016-11-03 23:11:05 UTC


Attachments (Terms of Use)
kickstart (193 bytes, text/plain)
2015-09-02 15:23 UTC, Jan Stodola
no flags Details
storage.log (203.33 KB, text/plain)
2016-05-12 10:09 UTC, Jan Stodola
no flags Details
anaconda.log (9.59 KB, text/plain)
2016-07-18 16:45 UTC, Jan Stodola
no flags Details
program.log (58.59 KB, text/plain)
2016-07-18 16:45 UTC, Jan Stodola
no flags Details
storage.log (228.31 KB, text/plain)
2016-07-18 16:46 UTC, Jan Stodola
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2158 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2016-11-03 13:13:55 UTC
IBM Linux Technology Center 131974 None None None 2018-12-20 13:58 UTC

Description Jan Stodola 2015-09-02 15:20:01 UTC
Description of problem:
The installer doesn't format unformatted DASD disks (formatted by cpfmtxa in CMS) when running a kickstart installation in text mode. Those disks are ignored during the installation.

Version-Release number of selected component (if applicable):
RHEL-7.0 GA
RHEL-7.1 GA
RHEL-7.2 Beta (anaconda-21.48.22.35-1.el7)

How reproducible:
always

Steps to Reproduce:
1. format a DASD disk in CMS using the "cpfmtxa" command
2. run a kickstart installation in text mode with the following commands in the kickstart file:

bootloader --location=mbr
zerombr
clearpart --all --initlabel
autopart

Actual results:
Unformatted DASD disk not formatted using dasdfmt during the installation

Expected results:
Unformatted DASD disk are formatted and used during the installation

Comment 5 Jan Stodola 2015-09-02 15:23:47 UTC
Created attachment 1069476 [details]
kickstart

Comment 6 Jan Stodola 2015-09-02 15:24:52 UTC
DASD disks after the installation:

[root@rtt7 ~]# lsblk
NAME                 MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
dasda                 94:0    0  2.3G  0 disk 
├─dasda1              94:1    0  500M  0 part /boot
└─dasda2              94:2    0  1.8G  0 part 
  ├─rhel_rtt700-root 253:0    0  3.6G  0 lvm  /
  └─rhel_rtt700-swap 253:1    0  472M  0 lvm  [SWAP]
dasdb                 94:4    0  2.3G  0 disk 
└─dasdb1              94:5    0  2.3G  0 part 
  └─rhel_rtt700-root 253:0    0  3.6G  0 lvm  /
[root@rtt7 ~]# lsdasd 
Bus-ID     Status      Name      Device  Type  BlkSz  Size      Blocks
==============================================================================
0.0.3527   active      dasda     94:0    ECKD  4096   2347MB    601020
0.0.3627   active      dasdb     94:4    ECKD  4096   2347MB    601020
0.0.3727   n/f         dasdc     94:8    ECKD                   
[root@rtt7 ~]#

Comment 7 Jan Stodola 2015-10-08 13:09:32 UTC
Not only unformatted, but also LDL disks are not formatted during kickstart installation in text mode when having the following line in the kickstart file:

clearpart --all --initlabel --cdl

Since I believe the root cause is the same, I'm using this bug for LDL disks as well. In case the root case is different, I will report a new bug.

Comment 9 IBM Bug Proxy 2016-02-23 17:41:06 UTC
------- Comment From vsandhya@in.ibm.com 2016-02-23 12:35 EDT-------
Any updates?

Comment 10 Mike McCune 2016-03-28 23:33:48 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 12 Jan Stodola 2016-05-12 10:08:21 UTC
Retested with anaconda-21.48.22.70-1.el7, but the unformatted DASD wasn't formatted during the installation. After the installation:

[root@rtt7 ~]# lsdasd 
Bus-ID     Status      Name      Device  Type  BlkSz  Size      Blocks
==============================================================================
0.0.3127   active      dasda     94:0    ECKD  4096   2347MB    601020
0.0.3227   active      dasdb     94:4    ECKD  4096   2347MB    601020
0.0.3027   n/f         dasdc     94:8    ECKD                   
[root@rtt7 ~]#

Moving back to ASSIGNED.

Comment 15 Jan Stodola 2016-05-12 10:09 UTC
Created attachment 1156625 [details]
storage.log

Comment 18 Jan Stodola 2016-07-18 16:44:49 UTC
Retested with anaconda-21.48.22.79-1.el7 - LDL DASD isn't formatted with CDL during kickstart installation in text mode (ks installation in vnc mode works fine).

Partitioning part of the kickstart file:

bootloader --location=mbr
zerombr
clearpart --all --initlabel --cdl
autopart

Installation logs will be attached, moving to ASSIGNED.

Comment 19 Jan Stodola 2016-07-18 16:45 UTC
Created attachment 1181184 [details]
anaconda.log

Comment 20 Jan Stodola 2016-07-18 16:45 UTC
Created attachment 1181185 [details]
program.log

Comment 21 Jan Stodola 2016-07-18 16:46 UTC
Created attachment 1181186 [details]
storage.log

Comment 24 Samantha N. Bueno 2016-08-19 20:12:58 UTC
https://github.com/rhinstaller/anaconda/pull/742

Comment 27 Jan Stodola 2016-08-29 08:54:51 UTC
Retested with anaconda-21.48.22.86-1.el7 and this issue is fixed, both unformatted and LDL formatted DASD disks are formatted with CDL in text mode.

Thanks, moving to VERIFIED.

Comment 31 errata-xmlrpc 2016-11-03 23:11:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html


Note You need to log in before you can comment on or make changes to this bug.