Bug 1259457 - The removal of "-i" and "-t" causes existing rngd environment to fail that make use of those options
The removal of "-i" and "-t" causes existing rngd environment to fail that ma...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rng-tools (Show other bugs)
6.8
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Neil Horman
Vilém Maršík
: ZStream
Depends On: 1258642
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 12:09 EDT by Jan Kurik
Modified: 2015-09-22 10:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A recent update of rng-tools removed the "-i" and "-t" options from the rngd daemon, which caused scripts that make use of these options to fail. This update adds these options back to maintain backward compatibility. Note that the "-t" option only exists to prevent script failures from occurring and has no functionality as the new rngd has no use for it.
Story Points: ---
Clone Of: 1258642
Environment:
Last Closed: 2015-09-22 10:01:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-09-02 12:09:52 EDT
This bug has been copied from bug #1258642 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 3 Neil Horman 2015-09-02 15:25:23 EDT
requested z-stream branch creation from rel-eng
Comment 5 Vilém Maršík 2015-09-07 09:15:13 EDT
Used Errata build (rng-tools-5-2.el6_7.x86_64) on 6.7-Server for verification:

[root@dell-pec5125-02 tmp]# man rngd | grep -A 2 '\-i\|-t.t '
       -i, --ignorefail
              Ignore repeated fips failures.

--
       -t nnn, --timeout=nnn
              Interval written to random-device when the entropy pool is full.
              Note that this  option  exists  for  backward  compatibility  in

[root@dell-pec5125-02 tmp]# rngd -f -i -t 999 -r /dev/random
(running, not crashing)

Looks verified.
Comment 7 errata-xmlrpc 2015-09-22 10:01:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1820.html

Note You need to log in before you can comment on or make changes to this bug.