Bug 125946 - Unclear dialog when saving alpha channel image to png
Unclear dialog when saving alpha channel image to png
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-14 10:02 EDT by Sitsofe Wheeler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 07:05:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photoshop image with alpha channel (18.34 KB, image/x-psd)
2004-06-14 10:03 EDT, Sitsofe Wheeler
no flags Details

  None (edit)
Description Sitsofe Wheeler 2004-06-14 10:02:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
I have some images orginally saved in PSD format and although they are
displayed correctly within The GIMP, attempts to export them to PNG or
BMP resulted in a completely black image. Despite an error dialog it
was not clear why this was happening.

Version-Release number of selected component (if applicable):
gimp-2.0.1-3

How reproducible:
Always

Steps to Reproduce:
1. Open a PSD file within The GIMP
2. Right mouse button the image and go to File -> Save a Copy...
3. In the selection dialog type test.png and make sure Determine File
Type: is on "By Extension". Click OK.
4. A dialog will pop up saying "You are about to save a channel (saved
selection) as PNG. This will not save visible layers.". Click Confirm.
5. Untick everything on the following Save as PNG dialog, set the
Compression Level to 9 and click OK.

Actual Results:  Black image is saved

Expected Results:  Visible image displayed within The GIMP to be saved.

Additional info:

Despite the error message, I did not realise there was some sort of
alpha channel saved with the image and *that* was what was being
saved. It would help if the error message had made some reference to
the word alpha since I am not at all familiar with channels (the image
had been given to me to convert).

Ideally The GIMP should default to saving the visible layers rather
than the alpha selection when saving to a format that cannot handle
the channel, perhaps by giving the user a discard channel button in a
similar way that there is a merge visible layers button.
Comment 1 Sitsofe Wheeler 2004-06-14 10:03:59 EDT
Created attachment 101106 [details]
Photoshop image with alpha channel
Comment 2 Nils Philippsen 2004-06-28 07:05:04 EDT
Your attached image opens with only one layer that has an alpha
channel. What happens is that not the background layer is selected but
the alpha channel which gets saved subsequently. To work around this
bug, select the background layer before saving. I will close this as
UPSTREAM, files the bug as
http://bugzilla.gnome.org/show_bug.cgi?id=145090
Comment 3 Nils Philippsen 2004-06-28 07:05:50 EDT
Argh -- "filed" of course.
Comment 4 Sitsofe Wheeler 2004-06-28 08:33:55 EDT
Thank you! I'll CC myself on the GNOME bugzilla bug

Note You need to log in before you can comment on or make changes to this bug.