Bug 125947 - kernel-2.6.6-1.427 pppd and modems unregister_netdevice message
kernel-2.6.6-1.427 pppd and modems unregister_netdevice message
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-14 10:14 EDT by Motor
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-19 08:18:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Motor 2004-06-14 10:14:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.14

Description of problem:
kernel-2.6.6-1.427 pppd and modems unregister_netdevice message

I've just install Fedora Core 2 (upgrade from FC1) and been using it
with no problems. However, after installing kernel-2.6.6-1.427 it
seems to have developed a strange problem with pppd. I'm using a 56k
modem, which I switch off when I want to disconnected from the
internet. With previous kernels (including 2.6.5-1.358) this didn't
cause any problems... but after installing kernel-2.6.6-1.427, I
started to get this message displayed at the console when switching
off the modem:

unregister_netdevice: waiting for ppp0 to become free. Usage count = 1

6 or 7 times with a few seconds inbetween each message. This lasts for
about 30 seconds and then clears. The big problem is that, while this
is occuring, no GNOME applications can be launched -- or rather they
do pop up eventually, just not until this "unregister_netdevice"
logjam has cleared.

It doesn't seem to occur every time the modem is switched off, and
switching back to kernel 2.6.5-1.358 seems to make the problem go away
(at least, I haven't seen it yet). 



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Connect to internet via modem
2. Run apps (say pan newsreader) which keep a connection
3. Switch off modem
    

Additional info:

Newbie speculation:

It would seem that if an app (say the pan newsreader) has a connection
open, then it causes this message and the subsequent blockage in app
start up because they try to lookup the hostname?


System specs:

Gigabyte k7 triton motherboard, with VIA KLE133 chipset.
AMD XP2000+
512Mb RAM
Matrox G550 gfx card.
56k modem
Comment 1 Craig Routledge 2004-06-17 22:11:27 EDT
As I understand it, this has been resolved in kernel build 435.  I and
others experienced the same problem which has been fixed with the
latest kernel update.

From the changelog:
* Sun Jun 13 2004 Arjan van de Ven <arjanv@redhat.com>
- add patch from DaveM to fix the ppp-keeps-iface-busy bug
 
Has this fixed it for you?
Comment 2 Motor 2004-06-18 05:07:22 EDT
Yes, it seems to be fixed. The problem does not occur for me after
installing 435.

Note You need to log in before you can comment on or make changes to this bug.