Bug 1259472 - [abrt] plasma-workspace: KCrash::defaultCrashHandler(int)(): kscreenlocker_greet killed by SIGSEGV
[abrt] plasma-workspace: KCrash::defaultCrashHandler(int)(): kscreenlocker_gr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: plasma-workspace (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:4bd37b49d1a031b15841898b97f...
:
: 1315551 1317098 1318096 1319474 1324146 1324654 1327147 1327357 1328538 1328631 1329114 1334498 1336934 1342730 1368627 (view as bug list)
Depends On:
Blocks: F24FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-09-02 12:37 EDT by Karel Volný
Modified: 2016-10-09 13:55 EDT (History)
48 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-09 10:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (34.75 KB, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details
File: cgroup (188 bytes, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details
File: core_backtrace (3.77 KB, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details
File: dso_list (19.23 KB, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details
File: environ (1.46 KB, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details
File: maps (89.85 KB, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details
File: mountinfo (3.04 KB, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details
File: namespaces (85 bytes, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details
File: open_fds (137 bytes, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details
File: proc_pid_status (1.00 KB, text/plain)
2015-09-02 12:37 EDT, Karel Volný
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 346118 None None None 2016-04-19 18:53 EDT
Qt Bug Tracker QTBUG-43827 None None None 2016-04-19 18:53 EDT
Qt Bug Tracker QTBUG-53677 None None None 2016-06-16 09:07 EDT

  None (edit)
Description Karel Volný 2015-09-02 12:37:07 EDT
Version-Release number of selected component:
plasma-workspace-5.4.0-4.fc23

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/kscreenlocker_greet --immediateLock --ksldfd 38
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/libexec/kscreenlocker_greet
global_pid:     3360
kernel:         4.2.0-0.rc6.git0.2.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (1 frames)
 #1 KCrash::defaultCrashHandler(int) at ../../src/kcrash.cpp:409
Comment 1 Karel Volný 2015-09-02 12:37:10 EDT
Created attachment 1069546 [details]
File: backtrace
Comment 2 Karel Volný 2015-09-02 12:37:11 EDT
Created attachment 1069547 [details]
File: cgroup
Comment 3 Karel Volný 2015-09-02 12:37:13 EDT
Created attachment 1069548 [details]
File: core_backtrace
Comment 4 Karel Volný 2015-09-02 12:37:14 EDT
Created attachment 1069549 [details]
File: dso_list
Comment 5 Karel Volný 2015-09-02 12:37:15 EDT
Created attachment 1069550 [details]
File: environ
Comment 6 Karel Volný 2015-09-02 12:37:17 EDT
Created attachment 1069551 [details]
File: limits
Comment 7 Karel Volný 2015-09-02 12:37:18 EDT
Created attachment 1069552 [details]
File: maps
Comment 8 Karel Volný 2015-09-02 12:37:20 EDT
Created attachment 1069553 [details]
File: mountinfo
Comment 9 Karel Volný 2015-09-02 12:37:21 EDT
Created attachment 1069554 [details]
File: namespaces
Comment 10 Karel Volný 2015-09-02 12:37:22 EDT
Created attachment 1069555 [details]
File: open_fds
Comment 11 Karel Volný 2015-09-02 12:37:23 EDT
Created attachment 1069556 [details]
File: proc_pid_status
Comment 12 George Getejanc 2015-12-09 02:40:50 EST
Another user experienced a similar problem:

Unten neben Uhr, rechts, tray-icon "Lautstärke", rechte maustaste, und, boom, error.

Es passiert, jedes zweites mal. Plasma absturtz.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell -s --crashes 1
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     6963
kernel:         4.2.6-301.fc23.x86_64
package:        plasma-workspace-5.4.3-3.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 13 J. Randall Owens 2015-12-13 15:11:42 EST
Another user experienced a similar problem:

I'd clicked the launcher, and started typing in a program name. Just before crash, I saw the program & its icon, but not the usual list of documents matching the string below that.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     14213
kernel:         4.2.6-301.fc23.x86_64
package:        plasma-workspace-5.5.0-2.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1024
Comment 14 Jacek Chrząszcz 2015-12-18 08:30:16 EST
Another user experienced a similar problem:

This happened (and it does happen quite often) when I tried to switch off my external monitor using (autorandr - a script based on) xrandr. Everything blows up, including the konsole I launch the command in, after some time the plasma sometimes returns (this time it did return when I issued some xrandr commands blindly), but e.g. konsoles do not.
May-be it is important that I change the --scale of my screen, i.e. I go from DP2-1@1x1+eDP1@0.65x0.65 to eDP1@1x1.
This blow-up happens almost every time I do that - I have to reboot after that. This happens on Lenovo T540p using a Dock, but note that I do not undock before the blow-up. This instability is frustrating...

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell -s --crashes 2
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     7714
kernel:         4.2.7-300.fc23.x86_64
package:        plasma-workspace-5.5.0-2.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 15 MartinG 2016-01-03 10:00:07 EST
Another user experienced a similar problem:

I pressed one of two volume tray icons, and tried to adjust the volume. plasma crashed.
I had both kmix system tray and "the other" volume system tray active. I think it was the other that made plasma crash.
I had both active, since I didn't want youtube videos to start at 100 % volume each time, and there was no "volume" plasmoid available when I searched. However, upon restart I suddenly had two.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     1776
kernel:         4.2.8-300.fc23.x86_64
package:        plasma-workspace-5.5.0-4.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 16 Christian Stadelmann 2016-01-12 07:38:18 EST
Another user experienced a similar problem:

I clicked on the "view person" plasma widget, then plasmashell crashed.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        plasmashell
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
kernel:         4.3.3-300.fc23.x86_64
package:        plasma-workspace-5.5.3-2.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
Comment 17 Derek Konigsberg 2016-01-12 22:32:20 EST
Another user experienced a similar problem:

Configured KDE Connect to link with my phone
Received a notification on my phone
Plasma crashed

No idea if these are related, and due to the instability of Plasma after upgrading to Fedora 23, they likely are not.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     3496
kernel:         4.3.3-300.fc23.x86_64
package:        plasma-workspace-5.5.3-2.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 18 Mathias Panzenböck 2016-01-25 07:42:15 EST
Another user experienced a similar problem:

I logged into KDE, then tried to start an application with krunner. During typing of the application name krunner crashed.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/krunner
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/krunner
global_pid:     1836
kernel:         4.3.3-301.fc23.x86_64
package:        plasma-workspace-5.5.3-4.fc23
reason:         krunner killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 19 Diego 2016-01-26 09:02:12 EST
Another user experienced a similar problem:

plasmashell crashed when I connected to a VPN network using NetworkManager

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     2087
kernel:         4.3.3-301.fc23.x86_64
package:        plasma-workspace-5.5.3-4.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 20 Diego 2016-02-05 05:13:57 EST
Another user experienced a similar problem:

This happens frequently. Some times, just using the Plasma Desktop (clicking here and there) it crashes, apparently without a specific reason.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell -s --crashes 1
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     2950
kernel:         4.3.4-300.fc23.x86_64
package:        plasma-workspace-5.5.4-1.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 21 sedrubal 2016-02-08 14:53:53 EST
Similar problem has been detected:

I recently connected to a network but beside this, I did nothing special, I think...

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     14237
kernel:         4.3.4-300.fc23.x86_64
package:        plasma-workspace-5.5.4-2.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 22 sedrubal 2016-02-15 17:29:10 EST
Similar problem has been detected:

 - Right click on the audio tray icon
 - Click on "Audio Volume Settings..."
 - Every second time it crashes on my machine...

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --crashes 1
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     5039
kernel:         4.3.5-300.fc23.x86_64
package:        plasma-workspace-5.5.4-2.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 23 Jonathan Wakely 2016-02-23 05:47:21 EST
I inserted a luks-encrypted USB drive, clicked on "Open in File Manager" when the device notification popped up, entered the passphrase for the disk, and got an error saying something like "Could not mount a disk". That was bogus, because it was showing as mounted in the device notifier. I clicked "Open in File Manager" again, and got the error again, then plasmashell crashed.
Comment 24 Steven Kelbley 2016-03-07 22:41:54 EST
*** Bug 1315551 has been marked as a duplicate of this bug. ***
Comment 25 Steven Kelbley 2016-03-09 18:08:01 EST
Similar problem has been detected:

Error showed up right as the desktop loaded when logging in.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     1455
kernel:         4.4.3-300.fc23.x86_64
package:        plasma-workspace-5.5.5-2.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 26 Christian Nourry 2016-03-11 18:45:33 EST
*** Bug 1317098 has been marked as a duplicate of this bug. ***
Comment 27 zhenyaratkov 2016-03-15 23:51:04 EDT
*** Bug 1318096 has been marked as a duplicate of this bug. ***
Comment 28 webdesigner 2016-03-20 08:49:59 EDT
*** Bug 1319474 has been marked as a duplicate of this bug. ***
Comment 29 Nova1987a 2016-03-21 01:54:54 EDT
Similar problem has been detected:

1. Let the user's friend send pidgin message or let the user fast switch the windows.
2. The crash happened.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     1476
kernel:         4.4.5-300.fc23.x86_64
package:        plasma-workspace-5.5.5-4.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            0
Comment 30 Diego 2016-03-23 11:47:07 EDT
Reported to upstream:
https://bugs.kde.org/show_bug.cgi?id=356703

Can anybody please add KDE Bugzilla URL to "See also"? I don't have enough permissions.
Comment 31 Jonathan Wakely 2016-03-23 11:53:33 EDT
(In reply to Diego from comment #30)
> Reported to upstream:
> https://bugs.kde.org/show_bug.cgi?id=356703
> 
> Can anybody please add KDE Bugzilla URL to "See also"? I don't have enough
> permissions.

I've added it to the external trackers instead.
Comment 32 Rahul Chowdhury 2016-04-05 12:03:23 EDT
*** Bug 1324146 has been marked as a duplicate of this bug. ***
Comment 33 Rahul Chowdhury 2016-04-06 17:26:49 EDT
*** Bug 1324654 has been marked as a duplicate of this bug. ***
Comment 34 Jannik Jochem 2016-04-14 06:55:29 EDT
*** Bug 1327147 has been marked as a duplicate of this bug. ***
Comment 35 Oleg 2016-04-14 17:15:27 EDT
*** Bug 1327357 has been marked as a duplicate of this bug. ***
Comment 36 Jeff Melton 2016-04-19 11:30:39 EDT
*** Bug 1328538 has been marked as a duplicate of this bug. ***
Comment 37 Oleg 2016-04-19 18:48:19 EDT
*** Bug 1328631 has been marked as a duplicate of this bug. ***
Comment 38 Robin Green 2016-04-20 04:06:18 EDT
Similar problem has been detected:

Resume from suspend

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell -s --crashes 1
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     26193
kernel:         4.4.6-301.fc23.x86_64
package:        plasma-workspace-5.5.5-5.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 39 andreic9203 2016-04-21 04:59:39 EDT
*** Bug 1329114 has been marked as a duplicate of this bug. ***
Comment 40 Diego 2016-04-22 08:21:42 EDT
Similar problem has been detected:

I unlocked the screen from kscreenlocker and this crash popped up.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell -s --crashes 1
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     8546
kernel:         4.4.6-301.fc23.x86_64
package:        plasma-workspace-5.5.5-5.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 41 tommaso.furieri 2016-04-28 19:05:22 EDT
Similar problem has been detected:

sleep mode fails wake up

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell -s --crashes 1
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     2833
kernel:         4.4.8-300.fc23.x86_64
package:        plasma-workspace-5.5.5-5.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 42 tommaso.furieri 2016-05-01 08:08:11 EDT
Similar problem has been detected:

setting up  widgets

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     1440
kernel:         4.4.8-300.fc23.x86_64
package:        plasma-workspace-5.5.5-5.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 43 Bruno Gambarini 2016-05-04 08:49:15 EDT
Similar problem has been detected:

i just try to open the bluetoot icon

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     2524
kernel:         4.4.8-300.fc23.x86_64
package:        plasma-workspace-5.5.5-5.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 44 Reartes Guillermo 2016-05-09 14:56:21 EDT
*** Bug 1334498 has been marked as a duplicate of this bug. ***
Comment 45 Reartes Guillermo 2016-05-09 15:02:03 EDT
plasmashell crashes after a dnf update, kde became UNUSABLE.
i reported it manually in BZ #1333982

i am using lxqt desktop, since kde is unusable since this friday.

today i was able to generate the backtrace for BZ #1333982, and abrt created BZ #1334498 (private dup of this one).
Comment 46 Ganesh Banghar 2016-05-17 16:32:12 EDT
*** Bug 1336934 has been marked as a duplicate of this bug. ***
Comment 47 jean-pierre cartal 2016-05-20 03:02:56 EDT
Similar problem has been detected:

Plasma crashed when enabling a previously saved wifi configuration

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     16994
kernel:         4.4.8-300.fc23.x86_64
package:        plasma-workspace-5.6.3-2.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 48 Fedora Update System 2016-05-31 16:45:06 EDT
qt5-qtdeclarative-5.6.0-11.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7e822d9239
Comment 49 Fedora Update System 2016-05-31 16:46:38 EDT
qt5-qtdeclarative-5.6.0-11.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e78000fedc
Comment 50 Fedora Update System 2016-06-01 04:28:30 EDT
qt5-qtdeclarative-5.6.0-11.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7e822d9239
Comment 51 Fedora Update System 2016-06-01 12:23:28 EDT
qt5-qtdeclarative-5.6.0-11.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e78000fedc
Comment 52 Fedora Blocker Bugs Application 2016-06-02 09:49:53 EDT
Proposed as a Freeze Exception for 24-final by Fedora user rdieter using the blocker tracking app because:

 A workaround for plasma crash issue that is unfortunately not uncommon, as can be seen by the number of duplicate reports both downstream and upstream.  Seems to affect some users more often (arguably making plasma unusable for them).
Comment 53 Adam Williamson 2016-06-03 18:45:02 EDT
+1, fixing commonly-encountered crashers on live images is a good FE justification.
Comment 54 Chris Murphy 2016-06-03 20:34:02 EDT
+1 FE, hard to imagine the fix involves a regression worse than frequent crashes, so let's fix it.
Comment 55 Björn Hermansson 2016-06-04 05:14:58 EDT
*** Bug 1342730 has been marked as a duplicate of this bug. ***
Comment 56 Geoffrey Marr 2016-06-06 15:50:38 EDT
This bug was discussed at the 2016-06-06 blocker review meeting [1] and determined to be an AcceptedFreezeException as many people have experienced this and fixing it is a good idea in a release-blocking desktop.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2016-06-06/f24-blocker-review.2016-06-06-16.00.txt
Comment 57 Fedora Update System 2016-06-09 10:10:08 EDT
qt5-qtdeclarative-5.6.0-11.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 58 Fedora Update System 2016-06-13 00:57:02 EDT
qt5-qtdeclarative-5.6.0-11.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 59 Björn Hermansson 2016-06-14 07:11:33 EDT
Similar problem has been detected:

When starting up the desktop comes up a short time before the screen goes black. From the black screen you can run application through Alt-F2 searching.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     1388
kernel:         4.5.6-200.fc23.x86_64
package:        plasma-workspace-5.6.4-1.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 60 Diego 2016-06-16 04:34:42 EDT
Please not that the patch to fix the problem has changed.
There's now a workaround committed in plasma-nm and different proposed patch to Qt:
https://bugs.kde.org/show_bug.cgi?id=346118#c131
Qt correct report is:
https://bugreports.qt.io/browse/QTBUG-53677
Comment 61 Rex Dieter 2016-06-16 09:07:33 EDT
We're already including the candidate for for QTBUG-53677 in the aforementioned qt5-qtdeclarative update.

We can look into backporting the plasma-nm fix as well.
Comment 62 Diego 2016-06-24 08:07:09 EDT
Similar problem has been detected:

Every time I wake up my workstation from display power saving (I have a two monitor setup) I get this crash.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     3984
kernel:         4.5.6-200.fc23.x86_64
package:        plasma-workspace-5.6.4-1.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 63 Diego 2016-06-24 08:15:27 EDT
(In reply to Diego from comment #62)
> Similar problem has been detected:
> 
> Every time I wake up my workstation from display power saving (I have a two
> monitor setup) I get this crash.
> 
> reporter:       libreport-2.6.4
> backtrace_rating: 4
> cmdline:        /usr/bin/plasmashell --shut-up
> crash_function: KCrash::defaultCrashHandler(int)
> executable:     /usr/bin/plasmashell
> global_pid:     3984
> kernel:         4.5.6-200.fc23.x86_64
> package:        plasma-workspace-5.6.4-1.fc23
> reason:         plasmashell killed by SIGSEGV
> runlevel:       N 5
> type:           CCpp
> uid:            1000

Please note that this is (always) happening to me with:
$ rpm -q qt5-qtdeclarative
qt5-qtdeclarative-5.6.0-11.fc23.x86_64
So the "try to connect to VPN / Wifi with changed MTU" problem seems to be fixed, while the "getting out of display power save" problem still leads to a crash.
Comment 64 Oliver Sampson 2016-07-16 08:19:23 EDT
Similar problem has been detected:

While pressing Fn-F7 to go through the different display combinations of my laptop and external monitor.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     8252
kernel:         4.5.7-202.fc23.x86_64
package:        plasma-workspace-5.6.5-1.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 65 Oliver Sampson 2016-07-18 12:38:33 EDT
Similar problem has been detected:

Logging in from a locked screen, and then using Fn-F7 to cycle through the second monitor combinations.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     24453
kernel:         4.5.7-202.fc23.x86_64
package:        plasma-workspace-5.6.5-1.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 66 Oliver Sampson 2016-07-21 13:44:59 EDT
Similar problem has been detected:

After resetting the display preferences for two monitors after logging in, when a second monitor was connected to the HDMI jack.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     4779
kernel:         4.6.4-201.fc23.x86_64
package:        plasma-workspace-5.6.5-1.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 67 Oliver Sampson 2016-07-22 10:52:45 EDT
Similar problem has been detected:

At login while using Fn-F7 to cycle through the different display with external monitor combinations.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     10437
kernel:         4.6.4-201.fc23.x86_64
package:        plasma-workspace-5.6.5-1.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 68 Oliver Sampson 2016-08-15 13:33:01 EDT
Similar problem has been detected:

It happend at login.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     1542
kernel:         4.6.5-200.fc23.x86_64
package:        plasma-workspace-5.7.3-2.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 69 Mebus 2016-08-20 03:19:36 EDT
*** Bug 1368627 has been marked as a duplicate of this bug. ***
Comment 70 Oliver Sampson 2016-10-09 13:55:57 EDT
Similar problem has been detected:

It happened while switching virtual desktops.

reporter:       libreport-2.6.4
backtrace_rating: 4
cmdline:        /usr/bin/plasmashell --shut-up
crash_function: KCrash::defaultCrashHandler(int)
executable:     /usr/bin/plasmashell
global_pid:     18533
kernel:         4.7.5-100.fc23.x86_64
package:        plasma-workspace-5.7.5-2.fc23
reason:         plasmashell killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Note You need to log in before you can comment on or make changes to this bug.