Bug 1259476 - [RFE] Add RHEVM Targeted Refreshes.
[RFE] Add RHEVM Targeted Refreshes.
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Performance (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Piotr Kliczewski
Matouš Mojžíš
rhev:provider:ems_refresh
: FutureFeature
Depends On:
Blocks: 1069707 1399475
  Show dependency treegraph
 
Reported: 2015-09-02 12:45 EDT by Alex Krzos
Modified: 2016-11-29 01:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This release adds the ability to refresh specific Red Hat Enterprise Virtualization virtual machines to improve CloudForms performance.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 10:59:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log output from EmsRefresh.refresh on 100 vms on rhevm medium sized provider (49.72 KB, application/x-gzip)
2015-09-02 12:45 EDT, Alex Krzos
no flags Details

  None (edit)
Description Alex Krzos 2015-09-02 12:45:19 EDT
Created attachment 1069557 [details]
log output from EmsRefresh.refresh on 100 vms on rhevm medium sized provider

Description of problem:
Refreshing specific Virtual Machines consume same amount of time regardless of the number of vm selected.

Version-Release number of selected component (if applicable):
5.4.1

How reproducible:
Always

Steps to Reproduce:
1. Perform Initial Refresh of a RHEVM provider
2. Select a specific number of VMs and perform a refresh x X times (Change number of targets)
3. 

Actual results:
test	99th
VM-1	139.9062
VM-25	138.6158
VM-50	141.3394
VM-75	140.8
VM-100	137.7111

99th percentile timing values are shown for 4 iterations of the tests.

Environment tested was a simulated RHEVM 3.4 environment consisting of:
1000 Virtual Machines (500 online)
50 Hosts
61 storage domains

Expected results:

Refresh against a single Vm should be far faster than refresh on 100 VMs for a medium sized environment.  (Benchmarking a similar VMware provider exhibits this behavior.)

Additional info:
full_refresh_threshold is bumped above 100 to prevent targeted refreshes against 100 VMs from becoming a provider refresh.

This becomes even more apparent as the scale of the environment is bumped to 3000 virtual machines.

It appears that RHEVM is refreshing all virtual machines according to log output during refreshes as there are log lines for updating hosts and vms that are not targets.
Comment 2 Alex Krzos 2015-09-02 13:08:24 EDT
I confirmed that RHEVM Refresh does not have capability to perform a targeted refresh yet, changed this to an RFE.
Comment 3 Matouš Mojžíš 2016-05-09 05:37:45 EDT
Verified in 5.6.0.5-beta2.4.20160503153816_1fb554f
Measured time was like ten times faster when refreshing single vm in 5.6.0.5 than in 5.5.2.
Also in evm.log there was only single vm update in 5.6.0.5, but in 5.5.2 all vms were updated.
Comment 5 errata-xmlrpc 2016-06-29 10:59:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.