Bug 1259484 - Missing PHP classes
Missing PHP classes
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: owncloud (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: James Hogarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 13:17 EDT by talk
Modified: 2016-04-01 10:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-01 10:18:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description talk 2015-09-02 13:17:50 EDT
Description of problem:

First error is:

"PHP Fatal error: Class 'Pimple\\Container' not found in /usr/share/owncloud/lib/private/appframework/utility/simplecontainer.php on line 32"

which is fixed by "dnf install -y php-pimple" as only "php-pimple-lib" is installed by dnf as dependency

Second error is:
PHP Fatal error:  Class 'RandomLib\\Factory' not found in /usr/share/owncloud/lib/private/security/securerandom.php on line 32
Version-Release number of selected component (if applicable):

How reproducible:
100%

Steps to Reproduce:

1. dnf install owncloud -y
2. visit https://localhost/owncloud

Actual results:

Blank page

Expected results:

ownCloud login page

Additional info:

php-ircmaxell-random-lib and php-ircmaxell-security-lib are installed (both  1.1.0-1.fc22)
Comment 1 Adam Williamson 2015-09-02 16:48:56 EDT
The second failure seems unexpected, because we patch the OC autoloader to fallback to system paths, and RandomLib\\Factory should be autoloadable according to PSR-0 rules, as it's located in /usr/share/php/RandomLib/Factory.php . Similarly, php-pimple-lib should be sufficient to satisfy the Pimple\\Container requirement. I'm testing to see if I can reproduce this.
Comment 2 Adam Williamson 2015-09-02 16:55:13 EDT
I can't reproduce this on a fresh F22 install with owncloud-8.0.5-1.fc22.noarch , php-ircmaxell-random-lib-1.1.0-1.fc22, and php-pimple-lib-3.0.1-1.fc22 (no php-pimple). OC works fine. I tested by installing with my test kickstart: 'inst.ks=https://www.happyassassin.net/ks/oc/oc8-httpd-sqlite.ks'. Going to http://ip/owncloud on the installed system worked fine, showed the OC web UI.

Can you post 'rpm -q owncloud; rpm -V owncloud'? Did you actually install one of the web server subpackages (owncloud-httpd or owncloud-nginx), and if so, which one?
Comment 3 talk 2015-09-03 05:13:35 EDT
owncloud-httpd was installed as I run apache2

# rpm -q owncloud; rpm -V owncloud
owncloud-8.0.5-1.fc22.noarch
Comment 4 Adam Williamson 2015-09-08 01:15:27 EDT
OK, sorry...but I can't actually do much with this now :/ I can't reproduce it here still, it works fine for me. Does this happen to you in a clean VM, if you can test that way? Have you done any local customization to the PHP config or anything like that?
Comment 5 Fedora Admin XMLRPC Client 2015-09-17 14:03:36 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 James Hogarth 2016-03-11 14:00:13 EST
Owncloud 8.1.5 is on its way to the updates-testing repo.

https://bodhi.fedoraproject.org/updates/owncloud-8.1.5-1.fc22

When it has been pushed it would be helpful if you could do the following to test:

dnf update --enablerepo=updates-testing owncloud\*
Comment 7 James Hogarth 2016-04-01 10:18:20 EDT
Closing the bug due to the lack of response to needsinfo in the past 3 weeks and 8.1.5 now being in stable F22

If you still experience issues please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.