This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1259498 - docker registry command does not provide IDs
docker registry command does not provide IDs
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity low (vote)
: Beta
: --
Assigned To: Partha Aji
Oleksandr Shtaier
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 14:58 EDT by Og Maciel
Modified: 2016-07-27 05:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:18:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11671 None None None 2016-04-22 12:51 EDT

  None (edit)
Description Og Maciel 2015-09-02 14:58:45 EDT
Description of problem:

The new 'docker registry' command has several subcommands that can use the ID for a registry to perform several CRUD actions but the ID is never displayed by 'docker registry list' or 'docker registry info'. Furthermore, the following fields are also never displayed: description, username, password

See the output of using hammer registry below:

hammer> docker registry
Usage:
     docker registry [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
 SUBCOMMAND                    subcommand
 [ARG] ...                     subcommand arguments

Subcommands:
 create                        Create a docker registry
 delete                        Delete a docker registry
 info                          Show a docker registry
 list                          List all docker registries
 update                        Update a docker registry

Options:
 -h, --help                    print help
hammer> docker registry create
Could not create the registry:
  Missing arguments for 'name', 'url'
hammer> docker registry create --name="Red Hat Docker Registry" --url="https://registry.access.redhat.com"
Docker registry created
hammer> docker registry list
------------------------|-----------------------------------
NAME                    | URL
------------------------|-----------------------------------
Red Hat Docker Registry | https://registry.access.redhat.com
------------------------|-----------------------------------
hammer> docker registry info -h
Usage:
     docker registry info [OPTIONS]

Options:
 --id ID
 --name NAME                   Name to search by
 -h, --help                    print help
hammer> docker registry info --name='Red Hat Docker Registry'
Name:       Red Hat Docker Registry
URL:        https://registry.access.redhat.com
Created at: 2015/09/02 18:44:24
Updated at: 2015/09/02 18:44:24

hammer> docker registry update -h
Usage:
     docker registry update [OPTIONS]

Options:
 --description DESCRIPTION
 --id ID
 --name NAME                   Name to search by
 --new-name NEW_NAME
 --password PASSWORD
 --url URL
 --username USERNAME
 -h, --help                    print help
hammer> docker registry update --name='Red Hat Docker Registry' --description='Updated this field'
Docker registry updated
hammer> docker registry info --name='Red Hat Docker Registry'
Name:       Red Hat Docker Registry
URL:        https://registry.access.redhat.com
Created at: 2015/09/02 18:44:24
Updated at: 2015/09/02 18:47:19

hammer> docker registry update --name='Red Hat Docker Registry' --username='Updated this field'
Docker registry updated
hammer> docker registry info --name='Red Hat Docker Registry'
Name:       Red Hat Docker Registry
URL:        https://registry.access.redhat.com
Created at: 2015/09/02 18:44:24
Updated at: 2015/09/02 18:47:46

hammer> docker registry update --name='Red Hat Docker Registry' --url='http://localhost'
Docker registry updated
hammer> docker registry info --name='Red Hat Docker Registry'
Name:       Red Hat Docker Registry
URL:        http://localhost
Created at: 2015/09/02 18:44:24
Updated at: 2015/09/02 18:48:15

hammer> docker registry update --name='Red Hat Docker Registry' --new-name='RH'
Docker registry updated
hammer> docker registry info --name='Red Hat Docker Registry'
Error: registry not found
hammer> docker registry info --name='RH'
Name:       RH
URL:        http://localhost
Created at: 2015/09/02 18:44:24
Updated at: 2015/09/02 18:48:46

hammer> docker registry delete -h
Usage:
     docker registry delete [OPTIONS]

Options:
 --id ID
 --name NAME                   Name to search by
 -h, --help                    print help
hammer> docker registry delete --name='RH'
Docker registry deleted
hammer> docker registry list
-----|----
NAME | URL
-----|----
hammer> docker registry info --name='RH'
Error: registry not found
 
Version-Release number of selected component (if applicable):

This is Sat6.1.2-SNAP1

* docker-1.7.1-108.el7.x86_64
* docker-selinux-1.7.1-108.el7.x86_64
* pulp-docker-plugins-0.2.5-1.el7sat.noarch
* python-pulp-docker-common-0.2.5-1.el7sat.noarch
* ruby193-rubygem-docker-api-1.17.0-1.1.el7sat.noarch
* ruby193-rubygem-foreman_docker-1.2.0.20-1.el7sat.noarch
* rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el7sat.noarch

How reproducible:


Steps to Reproduce:
1. Use the 'docker registry' command to create a new registry and then attempt to use any of its subcommand and pass the ID (i.e. --id) argument to perform any actions against the registry
2.
3.

Actual results:

The ID is never displayed by hammer and therefore one cannot use --id with its subcommands

Expected results:


Additional info:
Comment 1 Partha Aji 2015-09-02 15:46:55 EDT
Created redmine issue http://projects.theforeman.org/issues/11671 from this bug
Comment 2 Bryan Kearney 2015-09-02 16:04:58 EDT
Upstream bug assigned to paji@redhat.com
Comment 3 Bryan Kearney 2015-09-02 16:04:59 EDT
Upstream bug component is Container Management
Comment 5 Bryan Kearney 2016-01-04 16:38:03 EST
Upstream bug assigned to paji@redhat.com
Comment 6 Bryan Kearney 2016-02-20 20:11:47 EST
Moving to POST since upstream bug http://projects.theforeman.org/issues/11671 has been closed
Comment 9 Oleksandr Shtaier 2016-04-18 05:44:51 EDT
Work as intended. Verified on 6.2 SNAP 8.1

>hammer -u user -p pass docker registry create --name="Red Hat Docker Registry" --url="https://registry.access.redhat.com"
Docker registry created
>hammer -u user -p pass docker registry info --name='Red Hat Docker Registry'
ID:          4
Name:        Red Hat Docker Registry
URL:         https://registry.access.redhat.com
Description: 
Username:    
Created at:  2016/04/18 09:37:46
Updated at:  2016/04/18 09:37:46

>hammer -u user -p pass docker registry delete --id 4
Docker registry deleted
>hammer -u user -p pass docker registry info --name='Red Hat Docker Registry'
Error: registry not found
>hammer -u user -p pass docker registry create --name="Red Hat Docker Registry" --url="https://registry.access.redhat.com"
Docker registry created
>hammer -u user -p pass docker registry info --name='Red Hat Docker Registry'
ID:          5
Name:        Red Hat Docker Registry
URL:         https://registry.access.redhat.com
Description: 
Username:    
Created at:  2016/04/18 09:39:34
Updated at:  2016/04/18 09:39:34

>hammer -u user -p pass docker registry info --id 5
ID:          5
Name:        Red Hat Docker Registry
URL:         https://registry.access.redhat.com
Description: 
Username:    
Created at:  2016/04/18 09:39:34
Updated at:  2016/04/18 09:39:34

>hammer -u user -p pass docker registry update --id 5 --new-name 'RH'
Docker registry updated
>hammer -u user -p pass docker registry info --id 5
ID:          5
Name:        RH
URL:         https://registry.access.redhat.com
Description: 
Username:    
Created at:  2016/04/18 09:39:34
Updated at:  2016/04/18 09:40:35
Comment 11 errata-xmlrpc 2016-07-27 05:18:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.