Bug 1259533 - Add prequisite for subscription-manager in relation to hosts (satellite 6)
Add prequisite for subscription-manager in relation to hosts (satellite 6)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Host Configuration Guide (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity medium (vote)
: 6.2.10
: 6.2
Assigned To: Julie
Stephen Wadeley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 20:12 EDT by jnikolak
Modified: 2017-05-18 21:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-18 21:45:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jnikolak 2015-09-02 20:12:32 EDT
1. Proposed title of this feature request  


We need documentation review in relation to hosts that will be registering to the Satellite.

For instance: 

If a host tries to register using activation keys that has version Red hat 6.1
The subscription-manager version will not allow --org options.
So they can't register without updating subscription-manager


If a host registers using subscription-manager-1.8.22-1.el5

The product overrides option doesnt work. The product overrides, is so that customer doesn't manually have to enter subscription-manager repos --enable reponame
It's set by the Satellite via activations keys.

One customer resolved the issue by upgrading subscription-manager to:
beyond subscription-manager-1.10+
  
  
2. Who is the customer behind the request?  
Account: name and acct # <- please include both  
  
TAM customer: no/yes  no
SRM customer: no/yes  no
Strategic: no/yes  no
  
3. What is the nature and description of the request?  
  
Make a change to documentation in relation to subscription-manager

4. Why does the customer need this? (List the business requirements here)  
  
Its needed to inform customer, about the prequisites that a host requires.



5. How would the customer like to achieve this? (List the functional requirements here)  

Make adjustment to Satellite 6.1 docs

  
6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
  
n/a

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
  
n/a

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
  
Rhel 6

9. Is the sales team involved in this request and do they have any additional input?  
  

10. List any affected packages or components.  
  
11. Would the customer be able to assist in testing this functionality if implemented?
Comment 1 Stephen Wadeley 2016-11-07 15:43:15 EST
Hello

IIUC, we need to find all places were the use of activation keys on hosts is mentioned, and find a suitable place to warn that "a certain version" is required.

I think the version required is subscription-manager-1.10+

The Host Configuration Guide has:

Automated Host Registration with Activation Keys [1]

But I think a note at the beginning of the chapter [2] would be better


[1] https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/host-configuration-guide/65-automated-host-registration-with-activation-keys


[2] https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/host-configuration-guide/chapter-6-configuring-activation-keys
Comment 2 Andrew Dahms 2017-03-28 01:08:20 EDT
Assigning to Julie for review.

Julie - looks like we'll need to add a comment at the start of the chapter on configuring activation keys ([2] above) telling users they need subscription-manager version 1.10 or above for everything to work as anticipated.
Comment 3 Julie 2017-03-30 22:26:43 EDT
hi team,
I've reviewed this bug and checked the default subcription-manager version in the RHEL 7 and RHEL 6.7 (which is a quite old version of the 6.x) and they are all subscription-manager-1.14 or above, so I don't think adding a note about subscription-manager-1.10 makes sense anymore. This is a pretty old bug after all. 

I'll leave this bug opened for a few more days in case anyone has other feedback.

Kind regards,
Julie
Comment 4 Stephen Wadeley 2017-03-31 05:17:34 EDT
Hello Julie

The important thing is what versions of RHEL hosts might be used by a Sat6 user. Unless the Sat6 docs say RHEL6.0 and RHEL5 are not supported then then this bug is valid.

You could also try to find out which versions of RHEL did not already have subscription-manager-1.10 or higher when they were released.

Thank you

Note You need to log in before you can comment on or make changes to this bug.