Bug 1259538 - Do not start if fprintd.service is masked due to silent backtrace
Do not start if fprintd.service is masked due to silent backtrace
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks: 1298243
  Show dependency treegraph
 
Reported: 2015-09-02 20:21 EDT by M. Scherer
Modified: 2017-08-01 18:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 18:41:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M. Scherer 2015-09-02 20:21:48 EDT
Description of problem:
I just updated to RHEL 7.2 beta, and my gdm session failed to show a login form. After further investigation, it seems that having fprintd disabled is the culprit.

I do not remember why I did mask the service (likely because my fingerprint reader was not behaving correctly, but I do not remember the details), but it result into this backtrace:

(gnome-shell:19893): Gjs-WARNING **: JS ERROR: Exception in callback for signal: startup-prepared: Gio.IOErrorEnum: Erreur lors de l'appel de StartServiceByName pour net.reactivated.Fprint : GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit fprintd.service is masked.
_injectToMethod/klass[method]@resource:///org/gnome/gjs/modules/overrides/Gio.js:234
FprintManager@resource:///org/gnome/shell/gdm/fingerprint.js:26
ShellUserVerifier<._init@resource:///org/gnome/shell/gdm/util.js:136
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
_Base.prototype._construct@resource:///org/gnome/gjs/modules/lang.js:110
Class.prototype._construct/newClass@resource:///org/gnome/gjs/modules/lang.js:204
AuthPrompt<._init@resource:///org/gnome/shell/gdm/authPrompt.js:54
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
_Base.prototype._construct@resource:///org/gnome/gjs/modules/lang.js:110
Class.prototype._construct/newClass@resource:///org/gnome/gjs/modules/lang.js:204
LoginDialog<._init@resource:///org/gnome/shell/gdm/loginDialog.js:450
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
_Base.prototype._construct@resource:///org/gnome/gjs/modules/lang.js:110
Class.prototype._construct/newClass@resource:///org/gnome/gjs/modules/lang.js:204
ScreenShield<._ensureUnlockDialog@resource:///org/gnome/shell/ui/screenShield.js:972
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
ScreenShield<.showDialog@resource:///org/gnome/shell/ui/screenShield.js:913
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
_initializeUI/<@resource:///org/gnome/shell/ui/main.js:200
_emit@resource:///org/gnome/gjs/modules/signals.js:124
LayoutManager<._prepareStartupAnimation@resource:///org/gnome/shell/ui/layout.js:658
wrapper@resource:///org/gnome/gjs/modules/lang.js:169
LayoutManager<._loadBackground/signalId<@resource:///org/gnome/shell/ui/layout.js:605
_emit@resource:///org/gnome/gjs/modules/signals.js:124
SystemBackground<._init/id<@resource:///org/gnome/shell/ui/background.js:488


Version-Release number of selected component (if applicable):
# rpm -q gdm
gdm-3.14.2-12.el7.x86_64


How reproducible:
each time

Steps to Reproduce:
1. ln -s /dev/null /etc/systemd/system/fprint.service
2. systemctl daemon-reload
3. systemctl restart gdm.service

Actual results:
GDM do not show any widget to login, so i cannot connect neither as root nor as user. Nothing is written in the log, so the admin can hardly see what is the issue.

Expected results:
GDM show login widgets so i can connect

Additional info:
Comment 2 Ray Strode [halfline] 2015-09-03 08:49:56 EDT
we can add some error handling here, and should, but "systemctl mask" is a hammer approach to disabling fingerprint authentication. The right approach is to use authconfig.

proposing for 7.3
Comment 3 M. Scherer 2015-09-03 09:02:55 EDT
Just to clarify, my intent was not to disable fingerprint auth, but really not have fprintd running due to some side effect. The exact reason is lost in my memory, I suspect due to it adding some delay somewhere like ssh connexion or something. But if I cannot say why, I guess we maybe can't fix it properly, sorry about that.
Comment 6 Bohdan Milar 2017-06-21 07:25:46 EDT
Tested manually on x86_64 (VM) using gnome-shell-3.22.3-16.el7.x86_64 and gdm-3.22.3-11.el7.x86_64

GDM started correctly with login widgets and able to login user.
Comment 7 errata-xmlrpc 2017-08-01 18:41:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2098

Note You need to log in before you can comment on or make changes to this bug.