Bug 1259542 - [Radeon/Tonga] initrd ramdisk is missing ucode needed for AMDGPU
[Radeon/Tonga] initrd ramdisk is missing ucode needed for AMDGPU
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: linux-firmware (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-02 20:57 EDT by Edward O'Callaghan
Modified: 2015-12-14 08:55 EST (History)
4 users (show)

See Also:
Fixed In Version: 20150904-56.git6ebf5d57.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 08:55:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward O'Callaghan 2015-09-02 20:57:25 EDT
Description of problem:

A range of new AMD/Radeon cards need ucode/firmware blobs not found in the linux-firmware package current rev. These blobs are critical for the amdgpu kernel driver to correctly modload to support these cards [e.g., Radeon R9 380].

The kernel driver looks within /usr/lib/firmware/amdgpu/* for said fw/ucode, further these are needed within the initrd ramdisk for early boot to make sure the console is correctly displayed during boot.

Work-around:

  $ wget -r -l 1 http://people.freedesktop.org/~agd5f/radeon_ucode/tonga
  $ sudo mkdir /usr/lib/firmware/amdgpu
  $ sudo mv bla/bla/*.bin /usr/lib/firmware/amdgpu/
  $ sudo rmmod amdgpu
  $ sudo modprobe amdgpu

Version-Release number of selected component (if applicable):

 linux-firmware 20150715-54.git69640304.fc23
Comment 1 Josh Boyer 2015-09-03 09:16:14 EDT
I emailed the AMD firmware maintainer.  We'll see what he says.
Comment 2 Josh Boyer 2015-09-03 11:18:11 EDT
I've added a patch from the AMD maintainer.  This will be rolled out as an update shortly.
Comment 3 Fedora Update System 2015-09-03 11:31:21 EDT
linux-firmware-20150903-55.git38358cfc.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14992
Comment 4 Fedora Update System 2015-09-03 11:34:56 EDT
linux-firmware-20150903-55.git38358cfc.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14993
Comment 5 Fedora Update System 2015-09-03 11:40:20 EDT
linux-firmware-20150903-55.git38358cfc.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-14995
Comment 6 John Thacker 2015-09-04 10:30:13 EDT
The update works for me on Fedora 23, and now the modesetting xorg driver works and I get OpenGL 3.0. xorg-X11 is still looking for the amdgpu driver in order to get core profile support (OpenGL > 3.0; it will be 3.3 with the current LLVM and 4.1 when Fedora updates to LLVM 3.7.0), and Fedora doesn't have a package for that yet. (Perhaps xorg-x11-drv-amdgpu will be added when Mesa 11.0 is released.)
Comment 7 Fedora Update System 2015-09-04 19:20:19 EDT
linux-firmware-20150904-56.git6ebf5d57.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update linux-firmware'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15089
Comment 8 Fedora Update System 2015-09-06 17:57:10 EDT
kernel-4.2.0-300.fc23, linux-firmware-20150904-56.git6ebf5d57.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update kernel linux-firmware'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15131
Comment 9 Edward O'Callaghan 2015-09-07 06:35:16 EDT
Fixed ! Feel free to close this.
Comment 10 Fedora Update System 2015-09-07 12:35:06 EDT
kernel-4.2.0-300.fc23, linux-firmware-20150904-56.git6ebf5d57.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2015-09-18 16:51:42 EDT
linux-firmware-20150904-56.git6ebf5d57.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2015-10-12 13:02:55 EDT
linux-firmware-20151012-57.gitd82d3c1e.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1eb4524928
Comment 13 Fedora Update System 2015-10-13 14:20:51 EDT
linux-firmware-20151012-57.gitd82d3c1e.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update linux-firmware'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1eb4524928
Comment 14 Fedora Update System 2015-10-30 10:33:25 EDT
linux-firmware-20151030-58.git66d3d8d7.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-38c68e7875
Comment 15 Fedora Update System 2015-11-01 21:53:56 EST
linux-firmware-20151030-58.git66d3d8d7.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update linux-firmware'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-38c68e7875

Note You need to log in before you can comment on or make changes to this bug.