Bug 1259546 - regression -- COS cache doesn't properly mark vattr cache as invalid when there are multiple suffixes
regression -- COS cache doesn't properly mark vattr cache as invalid when the...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
Petr Bokoc
: Regression, ZStream
Depends On: 1179370
Blocks: 1172231 1179763 1260004
  Show dependency treegraph
 
Reported: 2015-09-02 21:31 EDT by Noriko Hosoi
Modified: 2016-05-10 15:21 EDT (History)
8 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-67.el6
Doc Type: Bug Fix
Doc Text:
COS cache now correctly adds all definitions A previous bug fix related to the Class of Service (COS) object cache introduced a regression which caused it to stop adding definitions after the first one, instead of adding all definitions. This problem has been fixed and the COS cache now correctly adds all definitions as designed.
Story Points: ---
Clone Of: 1179370
: 1260004 (view as bug list)
Environment:
Last Closed: 2016-05-10 15:21:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Noriko Hosoi 2015-09-03 15:58:19 EDT
Justification: The important feature Class of Service is not functioning since the rhel-6.7.0 release due to a regression.  We have to fix it as soon as possible.
Comment 11 Viktor Ashirov 2016-01-06 12:04:40 EST
Build tested: 389-ds-base-1.2.11.15-71.el6.x86_64

# py.test ds/dirsrvtests/tickets/ticket47981_test.py 
========================================================== test session starts ==========================================================
platform linux2 -- Python 2.6.6, pytest-2.8.5, py-1.4.31, pluggy-0.3.1
rootdir: /root/389test/ds/dirsrvtests/tickets, inifile: 
collected 2 items 

ds/dirsrvtests/tickets/ticket47981_test.py ..

====================================================== 2 passed in 160.35 seconds =======================================================

Marking as VERIFIED.
Comment 13 errata-xmlrpc 2016-05-10 15:21:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0737.html

Note You need to log in before you can comment on or make changes to this bug.