Bug 1259576 - SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /usr/sbin/ldconfig.
SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /usr/...
Status: CLOSED DUPLICATE of bug 1232748
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3dcda9740382993fa9320d28109...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 02:04 EDT by Heiko Adams
Modified: 2015-09-11 06:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-11 06:19:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2015-09-03 02:04:31 EDT
Description of problem:
SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /usr/sbin/ldconfig.

*****  Plugin catchall (100. confidence) suggests   **************************

If sie denken, dass es bash standardmässig erlaubt sein sollte, getattr Zugriff auf ldconfig file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep sh /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:firewalld_t:s0
Target Context                system_u:object_r:ldconfig_exec_t:s0
Target Objects                /usr/sbin/ldconfig [ file ]
Source                        sh
Source Path                   /usr/bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.3.39-1.fc22.x86_64
Target RPM Packages           glibc-2.21-5.fc22.x86_64
Policy RPM                    selinux-policy-3.13.1-128.1.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.0.5-300.fc22.x86_64 #1 SMP Mon
                              Jun 8 16:15:26 UTC 2015 x86_64 x86_64
Alert Count                   2
First Seen                    2015-06-25 09:19:32 CEST
Last Seen                     2015-06-25 09:19:33 CEST
Local ID                      7a9fc325-1284-4b9f-9c25-2349ed085ef8

Raw Audit Messages
type=AVC msg=audit(1435216773.257:738): avc:  denied  { getattr } for  pid=10894 comm="sh" path="/usr/sbin/ldconfig" dev="dm-2" ino=527288 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:ldconfig_exec_t:s0 tclass=file permissive=0


type=SYSCALL msg=audit(1435216773.257:738): arch=x86_64 syscall=stat success=no exit=EACCES a0=7fb5eb251ab0 a1=7ffcd9fbe3d0 a2=7ffcd9fbe3d0 a3=7ffcd9fbe400 items=0 ppid=10893 pid=10894 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=sh exe=/usr/bin/bash subj=system_u:system_r:firewalld_t:s0 key=(null)

Hash: sh,firewalld_t,ldconfig_exec_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-128.1.fc22.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.0-1.fc23.x86_64
type:           libreport

Potential duplicate: bug 1232748
Comment 1 Miroslav Grepl 2015-09-11 06:19:09 EDT

*** This bug has been marked as a duplicate of bug 1232748 ***

Note You need to log in before you can comment on or make changes to this bug.