Bug 1259595 - the redis resource agent should allow for use of a password to connect to redis
the redis resource agent should allow for use of a password to connect to redis
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: resource-agents (Show other bugs)
7.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Fabio Massimo Di Nitto
Leonid Natapov
: EasyFix, OtherQA, Patch, ZStream
Depends On: 1251484
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 02:52 EDT by Jan Kurik
Modified: 2015-09-15 05:38 EDT (History)
10 users (show)

See Also:
Fixed In Version: resource-agents-3.9.5-40.el7_1.9
Doc Type: Bug Fix
Doc Text:
In order to support authenticated communication between Redis and its clients, the Redis resource agent now supports client password communication by auto-detecting the settings from Redis configuration file.
Story Points: ---
Clone Of: 1251484
Environment:
Last Closed: 2015-09-15 05:38:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-09-03 02:52:13 EDT
This bug has been copied from bug #1251484 and has been proposed
to be backported to 7.1 z-stream (EUS).
Comment 4 Fabio Massimo Di Nitto 2015-09-03 05:12:54 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=1251484#c3

unit test
Comment 9 Ofer Blaut 2015-09-07 01:46:43 EDT
reproduction steps i used :

1. update resource rpm
2. edit config file on all hosts
3. disable resource
4. enable resource 


 

[root@overcloud-controller-1 ~]# redis-cli  -h 10.35.169.12 info
NOAUTH Authentication required.


[root@overcloud-controller-1 ~]# redis-cli -a foobared  -h 10.35.169.12 info | head -n 10
# Server
redis_version:2.8.21
redis_git_sha1:00000000
redis_git_dirty:0
redis_build_id:b33b557c4bcc5a9f
redis_mode:standalone
os:Linux 3.10.0-229.el7.x86_64 x86_64
arch_bits:64
multiplexing_api:epoll
gcc_version:4.8.3
[root@overcloud-controller-1 ~]# rpm -qa | grep resource
resource-agents-3.9.5-40.el7_1.9.x86_64


[root@overcloud-controller-1 ~]# pcs status | grep redis -A 3
 Master/Slave Set: redis-master [redis]
     Masters: [ overcloud-controller-1 ]
     Slaves: [ overcloud-controller-0 overcloud-controller-2 ]


redis logs:

[27220] 07 Sep 01:36:33.579 * DB loaded from disk: 0.000 seconds
[27220] 07 Sep 01:36:33.579 * The server is now ready to accept connections on port 6379
[27220] 07 Sep 01:36:33.579 * The server is now ready to accept connections at /var/run/redis/redis.sock
[27220] 07 Sep 01:36:33.844 * SLAVE OF no-such-master:6379 enabled (user request)
[27220] 07 Sep 01:36:34.579 * Connecting to MASTER no-such-master:6379
[27220] 07 Sep 01:36:34.581 # Unable to connect to MASTER: Resource temporarily unavailable
[27220] 07 Sep 01:36:34.713 * MASTER MODE enabled (user request)
[27220] 07 Sep 01:36:35.364 * Slave 10.35.169.11:6379 asks for synchronization
[27220] 07 Sep 01:36:35.364 * Full resync requested by slave 10.35.169.11:6379
[27220] 07 Sep 01:36:35.364 * Starting BGSAVE for SYNC with target: disk
[27220] 07 Sep 01:36:35.365 * Background saving started by pid 27571
[27571] 07 Sep 01:36:35.385 * DB saved on disk
[27571] 07 Sep 01:36:35.385 * RDB: 4 MB of memory used by copy-on-write
[27220] 07 Sep 01:36:35.483 * Background saving terminated with success
[27220] 07 Sep 01:36:35.483 * Synchronization with slave 10.35.169.11:6379 succeeded
[27220] 07 Sep 01:36:35.983 * Slave 10.35.169.13:6379 asks for synchronization
[27220] 07 Sep 01:36:35.983 * Full resync requested by slave 10.35.169.13:6379
[27220] 07 Sep 01:36:35.983 * Starting BGSAVE for SYNC with target: disk
[27220] 07 Sep 01:36:35.984 * Background saving started by pid 27573
[27573] 07 Sep 01:36:36.001 * DB saved on disk
[27573] 07 Sep 01:36:36.002 * RDB: 4 MB of memory used by copy-on-write
[27220] 07 Sep 01:36:36.084 * Background saving terminated with success
[27220] 07 Sep 01:36:36.084 * Synchronization with slave 10.35.169.13:6379 succeeded
Comment 11 errata-xmlrpc 2015-09-15 05:38:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1791.html

Note You need to log in before you can comment on or make changes to this bug.