Bug 1259606 - [Capsule installer]: redundant / duplicate steps in "Running the Installation and Configuration Program for Capsule Server"
[Capsule installer]: redundant / duplicate steps in "Running the Installation...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.1.1
All All
medium Severity low (vote)
: Beta
: 6.2
Assigned To: Byron Gravenorst
David O'Brien
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 03:24 EDT by Pavel Moravec
Modified: 2016-04-27 20:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-27 20:10:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Moravec 2015-09-03 03:24:31 EDT
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html-single/Installation_Guide/index.html#sect-Red_Hat_Satellite-Installation_Guide-Installing_Red_Hat_Satellite_Capsule_Server-Running_the_Installation_and_Configuration_Program_for_Capsule_Server


Section Number and Name: 
6.4. Running the Installation and Configuration Program for Capsule Server


Describe the issue: 
At the end of this section just below "Note", I see duplicate steps:

     Install the katello-ca-consumer-latest package from the Satellite server:

    # rpm -Uvh http://master.com/pub/katello-ca-consumer-latest.noarch.rpm

    Register the Capsule server with your organization:

    # subscription-manager register --org "Default Organization"

The same steps (with remaining mandatory subscription-manager commands) are already provided in "6.3. Obtaining the Required Packages for the Capsule Server". So the redundant steps should have already been executed.


Suggestions for improvement: 
Remove the two commands / steps.


Additional information:
Comment 1 Andrew Dahms 2015-12-06 19:15:31 EST
Assigning to Byron for review.
Comment 2 Byron Gravenorst 2015-12-07 21:21:36 EST
*** Documentation Link:
http://file.bne.redhat.com/~bgraveno/1259606/Sat_User_Guide/sect-Red_Hat_Satellite-Installation_Guide-Running_the_Installation_and_Configuration_Program_for_Capsule_Server.html

*** Changes:
The affected section was 7.4 in the doco(not 6.4).
Removed the duplicated steps:

     On the Capsule Server, install the katello-ca-consumer-latest package from the Satellite server:

    # rpm -Uvh http://satellite.example.com/pub/katello-ca-consumer-latest.noarch.rpm

    Register the Capsule Server with your organization by using the organization label:

    # subscription-manager register --org organization_label

    You will be prompted for your Red Hat Satellite user name and password. The Satellite Server administrator can configure new users. See the Users and Roles chapter in the Red Hat Satellite 6.2 User Guide for more information. 

Additionally, I removed the content that followed it:
The following sections will assist in configuring a Satellite Capsule Server for use with your Red Hat Satellite Server. This includes the following types of Satellite Capsule Servers:

    Satellite Capsule Server with content functionality.
    Satellite Capsule Server without content functionality. 

The reason for doing this was that the sections that followed are to do with installing the Capsule Server, and verifying the installation. 


Moving this on to ON_QA
Comment 3 Andrew Dahms 2015-12-09 17:25:11 EST
Raising needinfo against daobrien.

David - could you take a look at the changes for this bug?
Comment 4 David O'Brien 2015-12-20 20:16:21 EST
Seems ok, but keep an eye out for things like this:

 ⁠7.4.1. Installing a Capsule Server

You can install a Capsule Server by using customized parameters, depending on your intended use case. See capsule-installer --help for a list of the available parameters.

To install a Capsule by using the default method, run the following command (also found in the output from capsule-certs-generate): 


1. The section starts with an exception to what the section title states. Be better to start by describing what the section is about and the default operation, and document any exceptions after that.

2. "by using" is passive voice. Try to avoid.

Not blocker material, just bear in mind for future patches.
Comment 5 Andrew Dahms 2016-04-27 20:10:01 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.