Bug 1259608 - Python: cannot list project chroots until a build is created
Python: cannot list project chroots until a build is created
Status: CLOSED WONTFIX
Product: Copr
Classification: Community
Component: frontend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Valentin Gologuzov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 03:41 EDT by Radek Holy
Modified: 2015-12-01 01:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 07:27:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Holy 2015-09-03 03:41:56 EDT
(I miss a "Python API" component, the "frontend" component is described as "bugs related to web interface")


Description of problem:
There is no way, AFAIK, how to get the list of chroots set to a project until the first build is submitted.


Version-Release number of selected component (if applicable):
python-copr-1.58-1.fc21.noarch
I don't know the version of the server, it's the one that is running at https://copr.fedoraproject.org/.
Copr frontend build version: 1.66-1.fc21 


How reproducible:
Always


Steps to Reproduce:
1. Create a new project with e.g. a chroot fedora-22-x86_64
2. print(cl.get_project_details(name).chroots)


Actual results:
[]


Expected results:
['fedora-22-x86_64']


Additional info:
I'm not even sure whether I am using a public interface or not but I believe that the information should be available.
Comment 1 Valentin Gologuzov 2015-09-03 07:27:39 EDT
Acknowledged, but won't fix.
This is caused by design of existing api, it's possible to add true list of chroots, but it would require some work. 
I would prefer to spent it on the new API.
Comment 2 Radek Holy 2015-09-03 07:41:28 EDT
OK, not a big problem. Since I track some workarounds in my code and I refer to the related bug reports there, is there already a ticket (or whatever) somewhere which tracks the progress on the new API? Again, not a big deal if not...

Note You need to log in before you can comment on or make changes to this bug.