Bug 1259630 - BeagleBone black not booting from MMC
Summary: BeagleBone black not booting from MMC
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F23BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-09-03 08:46 UTC by Peter Robinson
Modified: 2015-09-12 01:07 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-12 01:07:48 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Robinson 2015-09-03 08:46:20 UTC
Beagle Bone doesn't find rootfs on external mSD, works fine on internal eMMC

Comment 1 Peter Robinson 2015-09-03 08:46:37 UTC
I've got to the bottom of the issue with mSD on the BeagleBone.

Basically the GPIO_OMAP option has changed [1] in the 4.2 cycle and
this is used for card detection of the mSD card. Prior to this we
didn't have it explicitly in our config [2] so it was being selected
by something else and it was being built in rather than modular as
only with 4.2 can it now be built as modular, and as a result it came
up on our radar and was enabled as a module [3].

If I explicitly put this in the initrd it works fine, we have the
omap_hsmmc modular too, but it's not pulled in automatically as
there's no module dependy by omap_hsmmc on gpio_omap.

In the short term I've built it back into the kernel [4] as that's the
way it's been for likely ever so it'll appear in the next kernel build
after rc8.git0.1

If you want to use any of the other 4.2 kernels you can regenerate the
initrd withe the following line in the /etc/dracut.conf file

add_drivers+="gpio_omap"

Comment 2 Peter Robinson 2015-09-03 08:50:33 UTC
This is fixed in kernel-4.2.0-0.rc8.git1.1.fc24, latest is f-23 GA is kernel-4.2.0-0.rc8.git0.1.fc23

Comment 3 Fedora Blocker Bugs Application 2015-09-03 08:56:37 UTC
Proposed as a Freeze Exception for 23-beta by Fedora user pbrobinson using the blocker tracking app because:

 The 4.2.0 GA kernel is already in updates testing, it would be useful to have the BeagleBone Black working as it's a widely available device for testing ARMv7. (I suspect getting 4.2 GA will be useful for other fixes too)

Comment 4 Adam Williamson 2015-09-10 19:36:34 UTC
Discussed at 2015-09-10 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-10/f23-blocker-review.2015-09-10-16.00.log.txt . It sounds like the required bits have in fact already made it to stable and nothing more should be needed here; Peter, could you please close this bug if everything is OK, or update it appropriately if something else is still needed? Thanks.

Comment 5 Peter Robinson 2015-09-11 11:02:41 UTC
I was awaiting a working TC/RC before I closed it.

Comment 6 Peter Robinson 2015-09-12 01:07:48 UTC
Confirmed it's working and looks fine with Beta TC5


Note You need to log in before you can comment on or make changes to this bug.