Bug 1259633 - Brittle configuration file for pam_pwquality
Brittle configuration file for pam_pwquality
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libpwquality (Show other bugs)
7.2
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Tomas Mraz
Eva Mrakova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 04:48 EDT by Laura Bailey
Modified: 2018-04-10 14:50 EDT (History)
8 users (show)

See Also:
Fixed In Version: libpwquality-1.2.3-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1259349
Environment:
Last Closed: 2018-04-10 14:50:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1014 None None None 2018-04-10 14:50 EDT

  None (edit)
Comment 2 Tomas Mraz 2015-09-03 05:42:18 EDT
Yes, this is already fixed in the current upstream version of libpwquality library where no spaces around the '=' are allowed.
Comment 3 Robert Krátký 2015-11-10 12:50:49 EST
(In reply to Tomas Mraz from comment #2)
> Yes, this is already fixed in the current upstream version of libpwquality
> library where no spaces around the '=' are allowed.

Hi Tomáš,

Just to clarify: this means that the correct syntax for RHEL < 7.3 is to use spaces? (Which will change when the upstream version gets into 7.3, and then no spaces will be allowed.)
Comment 4 Tomas Mraz 2015-11-10 13:11:07 EST
No, my sentence above was a little bit unclear. The current version upstream and in Fedora tolerates any number of spaces including zero. In RHEL-7 at least a single space on each side of '=' is required.
This is a request to backport the current Fedora behaviour to RHEL.
Comment 12 errata-xmlrpc 2018-04-10 14:50:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1014

Note You need to log in before you can comment on or make changes to this bug.