Bug 1259643 - totem expect python3 for some plugins
totem expect python3 for some plugins
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: totem (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bastien Nocera
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 05:17 EDT by Tomas Pelka
Modified: 2016-05-24 05:07 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.14.3-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-24 05:07:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2015-09-03 05:17:16 EDT
Description of problem:
For some plugins available in el7 totem expects libpeas to provide python3 loader.

(totem:12836): libpeas-WARNING **: python3loader: /usr/lib64/libpeas-1.0/loaders/libpython3loader.so: cannot open shared object file: No such file or directory

(totem:12836): libpeas-WARNING **: python3loader: /usr/lib64/libpeas-1.0/loaders/python3/libpython3loader.so: cannot open shared object file: No such file or directory

(totem:12836): libpeas-WARNING **: Could not load plugin loader 'python3'

(totem:12836): libpeas-WARNING **: The 'python3' plugin loader has not been enabled

(totem:12836): libpeas-WARNING **: The 'python3' plugin loader has not been enabled

Affected plugins:
MPRIS-Dbus interface
Python Console
Subtitle Downloader

Version-Release number of selected component (if applicable):
totem-3.14.3-2.el7
libpeas-1.12.1-1.el7

How reproducible:
100%

Steps to Reproduce:
1. open preferences for totem 
2. try to enable all plugins
3.

Actual results:
some plugins won't load, see description for more info

Expected results:
python3 plugins should not be enabled

Additional info:
Comment 1 Tomas Pelka 2015-09-03 05:18:23 EDT
To be honest not sure where this should be fixed on totem site, on libpeas site or on both sites.
Comment 2 Bastien Nocera 2015-09-03 12:24:23 EDT
(In reply to Tomas Pelka from comment #1)
> To be honest not sure where this should be fixed on totem site, on libpeas
> site or on both sites.

Let's start at the bottom of the stack then:
- Why isn't libpeas built with Python3 support?
- Why is libpeas throwing this many warnings when trying to load a Python3 plugin?
Comment 3 Bastien Nocera 2015-09-03 12:34:25 EDT
Tentative devel ack to get libpeas rebuilt with python3 support.
Comment 4 Bastien Nocera 2015-09-03 12:45:23 EDT
pygobject3-base only has support for Python2, not Python 3, hence the lack of Python3 support in libpeas. Reassigning to totem, where we'll remove the Python plugins (they're all Python3).
Comment 5 Bastien Nocera 2016-05-24 05:07:03 EDT
Was fixed in 3.14.3-4, and we shipped 3.14.3-5 in RHEL 7.2.

Note You need to log in before you can comment on or make changes to this bug.