Bug 1259656 - Wrong unit of memory_mb output of hardware introspection.
Wrong unit of memory_mb output of hardware introspection.
Status: CLOSED DUPLICATE of bug 1256421
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
6.0 (Juno)
x86_64 Linux
medium Severity low
: z6
: 8.0 (Liberty)
Assigned To: Lucas Alvares Gomes
Toure Dunnon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 05:50 EDT by Shinobu KINJO
Modified: 2015-09-03 20:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 07:56:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shinobu KINJO 2015-09-03 05:50:33 EDT
Description of problem:
HP BL460c Gen9 has 512 gb ram which is ddr4.
When I execute:

  openstack baremetal introspection bulk start

That resulted in:

+------------------------+-------------------------------------------------------------------------+
| Property               | Value                                                                   |
+------------------------+-------------------------------------------------------------------------+
 ...
| properties             | {u'memory_mb': u'512', u'cpu_arch': u'x86_64', u'local_gb': u'278',     |
 ...
+------------------------+-------------------------------------------------------------------------+

"memory_mb" doesn't have to be 512, has to be 524288.

But if the target hardware having ddr3 ram, output was fine. Meaning is that unit is mb.

If I did this:

  ironic node-update <node> replace properties/memory_mb=524288

everything is fine.

What I've already checked are:

    python-ironicclient-0.5.1-9.el7ost.noarch
    python-ironic-discoverd-1.1.0-5.el7ost.noarch
    openstack-ironic-conductor-2015.1.0-9.el7ost.noarch
    openstack-ironic-api-2015.1.0-9.el7ost.noarch
    openstack-ironic-common-2015.1.0-9.el7ost.noarch
    openstack-ironic-discoverd-1.1.0-5.el7ost.noarch

But I could not find out any bugs.
I'm quite sure I've missed something -;

Version-Release number of selected component (if applicable):

    python-ironicclient-0.5.1-9.el7ost.noarch
    python-ironic-discoverd-1.1.0-5.el7ost.noarch
    openstack-ironic-conductor-2015.1.0-9.el7ost.noarch
    openstack-ironic-api-2015.1.0-9.el7ost.noarch
    openstack-ironic-common-2015.1.0-9.el7ost.noarch
    openstack-ironic-discoverd-1.1.0-5.el7ost.noarch

How reproducible:

Probably yes. If we have same hardware having.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Mike Burns 2015-09-03 07:56:41 EDT

*** This bug has been marked as a duplicate of bug 1256421 ***

Note You need to log in before you can comment on or make changes to this bug.