Bug 125966 - kudzu recognises Iomega External FireWire HDD, but updfstab does not update /etc/fstab or /mnt
kudzu recognises Iomega External FireWire HDD, but updfstab does not update /...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-14 12:43 EDT by Darren Brierton
Modified: 2014-03-16 22:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-29 00:12:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Brierton 2004-06-14 12:43:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Galeon/1.3.14

Description of problem:
I finally installed FC2 and immediately updated to 2.6.6-1.427.
FireWire seems to be working absolutely fine: my external Iomega 120GB
FireWire drive was detected and the nightly backup onto it seems to
have gone without incident. I have copied large (~400MB) files to and
from it without incident so far.

There was only one thing regarding this that struck me as not quite
right, but it's not a problem with the kernel but rather with kudzu.
When I first booted into 2.6.6-1.427 with the FireWire drive attached
kudzu recognised the device and asked if I wanted to configure it to
which I said yes. However, kudzu/updfstab did not create a mount point
for it like it does for CD drives and floppies which I think it
should. I created an entry in fstab and a mount point in /mnt, but
still no icon for the drive showed up on my GNOME desktop even when
the device was mounted. I then added the option "users" to the fstab
entry and an icon appeared on the desktop. None of that was really a
problem for me, but a newbie would have just thought that FC2 was
failing to see the external drive.


Version-Release number of selected component (if applicable):
1.1.62-1

How reproducible:
Always

Steps to Reproduce:
1. Run a FireWire enabled kernel like 2.6.6-1.427
2. Connect an external FireWire drive.
    

Actual Results:  No entries in /etc/fstab or /mnt created. Drive is
invisible to user unless they know it is /dev/sd? and know how to
mount it.

Expected Results:  updfstab creates a mountpoint and an entry in
/etc/fstab and drive is automatically mounted and appears on desktop.

Additional info:

Creating a mountpoint and an entry in fstab is not exactly hard, but
it would confuse a normal non-techie user. Also, having a permanent
entry in fstab for the firewire drive is annoying because on boot
fstab is read before the firewire drivers have been loaded and
therefore generates an error -- if you are using rhgb the view
switches to details at mounting local disks which makes it look like
an error has occured (well technically it has). Again, this could be
disarming for a non-techie user.
Comment 1 Bill Nottingham 2004-06-29 00:12:55 EDT
We normally don't add entries for hard drives (usb or firewire.) This
may change with gnome-volume-manager and HAL in the future. 

Note You need to log in before you can comment on or make changes to this bug.