Bug 1259664 - dnf and gnome-software show different updates
dnf and gnome-software show different updates
Status: CLOSED DUPLICATE of bug 1215015
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-03 06:03 EDT by Tim Niemueller
Modified: 2015-09-08 03:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-08 03:55:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Niemueller 2015-09-03 06:03:40 EDT
Description of problem:
Today I got a notification about available software updates. Since I find it utterly annoying that every update install now forces a reboot, I prefer to just install the updates on the console afterwards.

However, "dnf update" shows less updates than what is shown in gnome-software. After a "dnf clean all" and another "dnf update" it shows all 

tim@palomino:[/opt]# sudo dnf update
Last metadata expiration check performed 1:25:15 ago on Thu Sep  3 10:27:04 2015.
Dependencies resolved.
======================================================================================================================================
 Package                                  Arch                  Version                                  Repository              Size
======================================================================================================================================
Upgrading:
 control-center                           x86_64                1:3.16.3-1.fc22                          updates                4.3 M
 control-center-filesystem                x86_64                1:3.16.3-1.fc22                          updates                 23 k
 gnome-settings-daemon                    x86_64                3.16.3-1.fc22                            updates                1.1 M
 thunderbird                              x86_64                38.2.0-2.fc22                            updates                 60 M
 vim-filesystem                           x86_64                2:7.4.827-1.fc22                         updates                 22 k
 vim-minimal                              x86_64                2:7.4.827-1.fc22                         updates                465 k
 webkitgtk4                               x86_64                2.8.5-2.fc22                             updates                 20 M
 xorg-x11-drv-intel                       x86_64                2.99.917-15.20150729.fc22                updates                677 k

Transaction Summary
======================================================================================================================================
Upgrade  8 Packages

tim@palomino:[/opt]# sudo dnf clean all

tim@palomino:[/opt]# sudo dnf update
insync repo                                                                                           298 kB/s | 254 kB     00:00    
google-talkplugin                                                                                     126 kB/s | 2.7 kB     00:00    
Fedora 22 - x86_64                                                                                     18 MB/s |  41 MB     00:02    
RPM Fusion for Fedora 22 - Free - Updates                                                             747 kB/s |  73 kB     00:00    
Adobe Systems Incorporated                                                                             17 kB/s | 1.8 kB     00:00    
Dropbox Repository                                                                                    7.9 kB/s | 2.4 kB     00:00    
RPM Fusion for Fedora 22 - Nonfree - Updates                                                          351 kB/s |  28 kB     00:00    
RPM Fusion for Fedora 22 - Free                                                                       6.6 MB/s | 551 kB     00:00    
Fedora 22 - x86_64 - Updates                                                                           26 MB/s |  14 MB     00:00    
google-chrome                                                                                         157 kB/s | 3.7 kB     00:00    
RPM Fusion for Fedora 22 - Nonfree                                                                    1.3 MB/s | 170 kB     00:00    
Last metadata expiration check performed 0:00:00 ago on Thu Sep  3 11:53:39 2015.
Dependencies resolved.
======================================================================================================================================
 Package                                Arch                Version                                  Repository                  Size
======================================================================================================================================
Upgrading:
 control-center                         x86_64              1:3.16.3-1.fc22                          updates                    4.3 M
 control-center-filesystem              x86_64              1:3.16.3-1.fc22                          updates                     23 k
 gnome-settings-daemon                  x86_64              3.16.3-1.fc22                            updates                    1.1 M
 google-chrome-stable                   x86_64              45.0.2454.85-1                           google-chrome               46 M
 man-db                                 x86_64              2.7.1-8.fc22                             updates                    823 k
 openssh                                x86_64              6.9p1-6.fc22.1                           updates                    445 k
 openssh-askpass                        x86_64              6.9p1-6.fc22.1                           updates                     78 k
 openssh-clients                        x86_64              6.9p1-6.fc22.1                           updates                    645 k
 openssh-server                         x86_64              6.9p1-6.fc22.1                           updates                    468 k
 thunderbird                            x86_64              38.2.0-2.fc22                            updates                     60 M
 vim-filesystem                         x86_64              2:7.4.827-1.fc22                         updates                     22 k
 vim-minimal                            x86_64              2:7.4.827-1.fc22                         updates                    465 k
 webkitgtk4                             x86_64              2.8.5-2.fc22                             updates                     20 M
 xorg-x11-drv-intel                     x86_64              2.99.917-15.20150729.fc22                updates                    677 k

Transaction Summary
======================================================================================================================================
Upgrade  14 Packages

As you can see the updates are all from updates proper repo, not a third-party repo.

Is there a way to fix this? How does gnome-software determine the available updates then and get it right, while dnf updates does not?

This is on a fresh install, not an upgrade.


Version-Release number of selected component (if applicable):
dnf-1.1.0-2.fc22.noarch
gnome-software-3.16.5-1.fc22.x86_64


How reproducible:
Several times already

Steps to Reproduce:
1. See notification of update
2. dnf update

Actual results:
Sometimes dnf shows less update packages than gnome-software.

Expected results:
Upgrade packages should be the same at the same time.

Additional info:
See explanation above.
Comment 1 Michal Luscon 2015-09-08 03:55:42 EDT

*** This bug has been marked as a duplicate of bug 1215015 ***

Note You need to log in before you can comment on or make changes to this bug.